Reply
 
Thread Tools Display Modes
Old 04-25-2016, 07:45 AM   #1
Senior Member
 
OswegoLion's Avatar
 
Join Date: Apr 2014
Location: Port St. Lucie
Posts: 327
Loose connection to sewer line?

The plastic connector locks on loosely and water seeps out. Not sure the cause. It fit tightly last week when I used it. Help! Solution!
__________________

OswegoLion is offline   Reply With Quote
Old 04-25-2016, 07:53 AM   #2
Senior Member
 
RSchleder's Avatar
 
Join Date: Apr 2014
Location: Iowa
Posts: 1,411
Not sure how anyone can help you without pictures/more info. At this point we'd be simply guessing! What have you done to investigate the problem????
__________________

__________________
Days camping (2016)----181 days
Days camping (2017) --- 82 days
2016 Wildcat MAXX 28RKX (33' TT), 2007 13' Scamp
2015 Ram Laramie Hemi, w/air suspension
30 years RV'ing
11 different RV's
RSchleder is offline   Reply With Quote
Old 04-25-2016, 08:16 AM   #3
Senior Member
 
Join Date: Jul 2010
Location: Waynesville
Posts: 13,890
My WAG is you Lost your "sealing Ring" from inside your Female connector! Youroo!!
__________________
youroo is offline   Reply With Quote
Old 04-25-2016, 08:18 AM   #4
Senior Member
 
SeaDog's Avatar
 
Join Date: Jan 2016
Location: Idaho
Posts: 6,247
X2 with seal, stop at camping world and get a new seal for the cap or just replace the cap
__________________
Retired Navy
Jake my sidekick (yellow Lab)
2017 RAM 2500 CC 4X4 Cummins Diesel
2016 Flagstaff 26 FKWS
AF&AM & El Korah Shrine of Idaho
SeaDog is offline   Reply With Quote
Old 04-25-2016, 08:24 AM   #5
Site Team
 
Flybob's Avatar
 
Join Date: Oct 2014
Posts: 10,293
Check and or lube your gate valve. If working properly, there should not be any liquid between it and the cap.
__________________

2015 Freedom Express 248RBS
TV 2015 Silverado HD2500 Duramax
TST Tire Monitors
Honda 2000I + Companion
2 100W solar panels
Flybob is online now   Reply With Quote
Old 04-25-2016, 08:33 AM   #6
Senior Member
 
Join Date: Jul 2010
Location: Waynesville
Posts: 13,890
Quote:
Originally Posted by Flybob View Post
Check and or lube your gate valve. If working properly, there should not be any liquid between it and the cap.
Come on people they said the "Hose is loose" they said nothing about the Cap! Youroo!!
__________________
youroo is offline   Reply With Quote
Old 04-25-2016, 08:40 AM   #7
Senior Member
 
OswegoLion's Avatar
 
Join Date: Apr 2014
Location: Port St. Lucie
Posts: 327
Close this topic. Seal was the problem. Thanks for your help.
OswegoLion is offline   Reply With Quote
Old 04-25-2016, 08:50 AM   #8
Senior Member
 
Join Date: Jul 2010
Location: Waynesville
Posts: 13,890
Quote:
Originally Posted by OswegoLion View Post
Close this topic. Seal was the problem. Thanks for your help.
OK! Youroo!!
__________________

__________________
youroo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:06 PM.


×