Reply
 
Thread Tools Display Modes
Old 12-29-2013, 04:35 PM   #1
Senior Member
 
Join Date: Apr 2013
Location: Houston, Texas
Posts: 407
Problems with my Flagstaff Super Lite 27 RLWS

Well the problems with this Flagstaff have started, and although I am loath to take it to the dealer I am afraid l have no other choice. Besides its under warranty. Newer had any issues with my previous Jayco's stove or radio though it had no slide.

- #1 Slide (dinette) stopped working just before a camping trip. Luckily there is a crank.
- Oven had a problem staying lit since day 1. Has a dumb soft popping sound as the burner (or pilot?) tries to stay alight.
- Right rear burner is default to light using the ignitor. Sometimes have to use a butane lighter.
- Radio decided to stop finding any stations at all. Antenna was slightly bent at the tip but the base was fine on the roof. Worked last camping trip and the only thing since then was the Camping World installation of a Fantastic Vent ceiling fan 6 inches away from the ceiling light that would have been tapped for power, and 3-4 ft away from the antenna. Hardly think the antenna cable would have been damaged.

l am pleased with the Fantastic Vent though.
__________________

__________________
Regards,
Wayne
2014 Flagstaff Super Lite 27RLWS Emerald Edition | Equal-i-zer 1200/12,000 4-point WDH
2010 GMC Sierra SLE 5.3L | K&N filter | Hypertech Max Energy tune | Prodigy P3
Wmoses is offline   Reply With Quote
Old 12-29-2013, 08:45 PM   #2
Senior Member
 
Indymule's Avatar
 
Join Date: Dec 2012
Posts: 503
The slide not working is a bigger problem and will need to return to the dealer.

The oven is a common problem. Not sure how you are lighting the pilot but you have to hold the knob in for what seems like a long time to let the thermal coupler warm up enough to keep gas flowing.

The radio antenna probably unplugged from the back of the unit. This may have been from the tech fishing the power line but more likely was not plugged in good and solid and came out while driving down the road.

Don't let it upset you too much, just shake them out now so you can enjoy the summer.
__________________

__________________
Jay & Maria - Camp Dogs Jackson & Joplin
2015 Rockwood 2604WS Emerald
Hensley Arrow hitch
2015 Ford F350 Crewcab Lariat Diesel
Ham Callsign K9NDY
Indymule is offline   Reply With Quote
Old 12-29-2013, 08:57 PM   #3
Senior Member
 
Join Date: Jul 2010
Location: Waynesville
Posts: 12,031
Quote:
Originally Posted by Indymule View Post
The slide not working is a bigger problem and will need to return to the dealer.

The oven is a common problem. Not sure how you are lighting the pilot but you have to hold the knob in for what seems like a long time to let the thermal coupler warm up enough to keep gas flowing.

The radio antenna probably unplugged from the back of the unit. This may have been from the tech fishing the power line but more likely was not plugged in good and solid and came out while driving down the road.

Don't let it upset you too much, just shake them out now so you can enjoy the summer.
What He said! Youroo!!
__________________
youroo is offline   Reply With Quote
Old 12-29-2013, 11:19 PM   #4
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
The slide not operating is probably just a blown fuse...have you looked in the 12V fuse panel or near the battery?

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 12-29-2013, 11:36 PM   #5
Senior Member
 
Join Date: Apr 2013
Location: Houston, Texas
Posts: 407
Thanks guys. I was suspecting the antenna since the problem was with getting reception on any band on the radio. I could pull the head unit to see what happened but figured since it was gong in anyway I'd leave it to the dealer. I have some time before breaking camp in the morning and may investigate further.

As for the oven - yes my wife lights the pilot correctly, and is quite the expert at it. The pilot light works as long as the temp is not turned up for actual oven use, then the problem occurs. Yes I am aware that it is a common problem - something about the thermocouple possibly not being close enough to the pilot light, seemed to be a common diagnosis. Pretty dumb quality issue if you ask me. Maybe Atwood makes a better stove /oven than the Suburban because I had no problems with the Atwood in my previous RV.

Just a little ticked at the moment given what I spent for this RV and it has only seen 4 months of camping. The slide was only deployed maybe 8 times?
__________________
Regards,
Wayne
2014 Flagstaff Super Lite 27RLWS Emerald Edition | Equal-i-zer 1200/12,000 4-point WDH
2010 GMC Sierra SLE 5.3L | K&N filter | Hypertech Max Energy tune | Prodigy P3
Wmoses is offline   Reply With Quote
Old 12-29-2013, 11:48 PM   #6
Senior Member
 
Join Date: Apr 2013
Location: Houston, Texas
Posts: 407
Quote:
Originally Posted by Dave_Monica View Post
The slide not operating is probably just a blown fuse...have you looked in the 12V fuse panel or near the battery?

Dave
Thanks Dave. Looked at the fuses and breakers in the Control Panel and all seems fine. Should not be a fuse near the battery as all other systems work, including my other 2 slides.

The way the side failed was like this - DW was retracting it and it was coming in normally and when it contacted the trailer side there was no clutch slipping noise as is normal. It just stopped with no clutch noise (we only allow 2 - 3 clicks). Wanting to ensure that the seal was tight I told DW to move the slide out at bit then bring it back in, which was done successfully, again with no clutch noise. After that the motor stopped responding to the switch. No sound no nothing - dead. l will look at the fuses again in the morning just to be sure.
__________________
Regards,
Wayne
2014 Flagstaff Super Lite 27RLWS Emerald Edition | Equal-i-zer 1200/12,000 4-point WDH
2010 GMC Sierra SLE 5.3L | K&N filter | Hypertech Max Energy tune | Prodigy P3
Wmoses is offline   Reply With Quote
Old 12-30-2013, 05:42 AM   #7
Member
 
Join Date: Jan 2013
Location: Marietta, GA
Posts: 91
Hope your punch list gets solved. I do not see any big issues after the stove and slide. I worked out of a 21' Sunline for years, electrician on nuclear powerhouses across the states. Best thing I learned? There is no perfect TT. I just bought a new 21FRBS Micro Lite and for me its near perfect. Forest River uses very good products, BUT people install them and there lays the problems. The first 3-4 outings are shake downs to have construction problems occur. Have your dealer earn his money and you have some wonderful outings.
__________________
SparkeyBob is offline   Reply With Quote
Old 12-30-2013, 10:38 AM   #8
Senior Member
 
cat1956's Avatar
 
Join Date: Jun 2008
Location: Chelsea, Alabama
Posts: 323
With my battery disconnect switch off that slide is the only thing that will still work. That tells me it is one of the fuses under the trailer at the hot water heater.
__________________
cat1956 is offline   Reply With Quote
Old 12-30-2013, 11:09 AM   #9
Senior Member
 
Join Date: Apr 2013
Location: Houston, Texas
Posts: 407
Quote:
Originally Posted by cat1956 View Post
With my battery disconnect switch off that slide is the only thing that will still work. That tells me it is one of the fuses under the trailer at the hot water heater.
You maybe on to something. In my WH compartment there is the Control module for the slide out, and AAMOF l looked there first to see if there was a fuse or some sort of reset switch. There was nothing obvious and if you look at the attached photos, there seems to be some indication that if a button was pressed the LEDs would flash allowing a diagnosis of the problem. Don't know if the tiny white disk is the button to be pressed. Since I will be breaking camp soon I will press the disk.



__________________
Regards,
Wayne
2014 Flagstaff Super Lite 27RLWS Emerald Edition | Equal-i-zer 1200/12,000 4-point WDH
2010 GMC Sierra SLE 5.3L | K&N filter | Hypertech Max Energy tune | Prodigy P3
Wmoses is offline   Reply With Quote
Old 12-30-2013, 01:30 PM   #10
Senior Member
 
Join Date: Jan 2012
Location: Upper East Tennessee
Posts: 289
May be mistaken but I think that is the controller for the wardrobe slide.
__________________

__________________
2013 Flagstaff 27RLWS
2014 Ford F150 Ecoboost
30 nights in 2015 so far
roanmountaincampers is offline   Reply With Quote
Reply

Tags
flagstaff

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:14 AM.