Reply
 
Thread Tools Display Modes
Old 06-28-2014, 08:37 PM   #1
Senior Member
 
Vpierce's Avatar
 
Join Date: Jun 2013
Posts: 116
Safe-t-alarm.

We came home from dinner and our camper is sitting in our driveway. I heard a beep periodically. Our safe-t-alarm is going off and we don't know why. We are getting ready to leave in a couple of days. Any suggestions on what we need to do?
Thanks


Sent from my iPhone using Forest River Forums
__________________

Vpierce is offline   Reply With Quote
Old 06-28-2014, 08:42 PM   #2
Junior Member
 
Join Date: Jun 2014
Posts: 12
Check you smoke detecter batt.
__________________

tclark is offline   Reply With Quote
Old 06-28-2014, 08:44 PM   #3
Site Team
 
dcheatwood's Avatar
 
Join Date: Nov 2011
Posts: 4,124
Are you plugged in to power? If not, and 12v battery is low it could cause it.
Is it LP alarm or carbon monoxide?
__________________
2018 Forester 3011 DS

dcheatwood is offline   Reply With Quote
Old 06-28-2014, 09:12 PM   #4
Senior Member
 
Vpierce's Avatar
 
Join Date: Jun 2013
Posts: 116
We checked the water in our battery and put more in there and we plugged the unit in so we are good to go. Thank you! It was low voltage. I appreciate the help!



Sent from my iPhone using Forest River Forums
Vpierce is offline   Reply With Quote
Old 06-28-2014, 10:18 PM   #5
Site Team
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 19,612
if you're not going to keep the trailer plugged into shore power, you need to install a battery disconnect switch.
otherwise, the parasitic power drains will empty your battery and you have the same issue again.

by the way, what's a Safe-t-alarm? is that a brand name?
__________________
Dan-Retired California Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 SCREW XTR 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH
bikendan is online now   Reply With Quote
Old 06-29-2014, 03:57 PM   #6
Site Team
 
dcheatwood's Avatar
 
Join Date: Nov 2011
Posts: 4,124
Quote:
Originally Posted by Vpierce View Post
We checked the water in our battery and put more in there and we plugged the unit in so we are good to go. Thank you! It was low voltage. I appreciate the help!



Sent from my iPhone using Forest River Forums
Good deal.
__________________
2018 Forester 3011 DS

dcheatwood is offline   Reply With Quote
Old 06-29-2014, 07:01 PM   #7
Senior Member
 
Vpierce's Avatar
 
Join Date: Jun 2013
Posts: 116
Yes that's the name of the annoying thing! My husband disconnected it so we should be fine now. I don't know why the salesperson couldn't have just told us that during our walk through. Oh well it's a learning experience. We feel silly because this is not our first Travel trailer. We have another one but we always leave it at a campground at the lake.


Sent from my iPhone using Forest River Forums
__________________

Vpierce is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:10 AM.


×