Reply
 
Thread Tools Display Modes
Old 04-25-2008, 03:15 PM   #1
Member
 
Join Date: Nov 2007
Posts: 72
1st Trip Trouble

WE JUST RETURNED FROM OUR FIRST OUTING IN OUR NEW
8317SS. EVERYTHING WENT GREAT EXEPT WHEN WE TRIED TO WATCH
A DVD WE HAD TONS OF STATIC IN THE SARROUND SOUND.
THE WHEN WE TRIED AGAIN THE WHOLE RADIO/DVD/SURROUND DIED!
JUST DIED - NO POWER - NOTHING.
OTHER THAN THAT EVERYTHING ELSE WAS JUST GREAT!!!!!!!
__________________

HOWIE BEDELL is offline   Reply With Quote
Old 04-25-2008, 03:26 PM   #2
Senior Member
 
Join Date: Aug 2006
Posts: 1,552
Is your unit Concertone Crap??
__________________

__________________

Hokiehall is offline   Reply With Quote
Old 04-25-2008, 03:29 PM   #3
Member
 
Join Date: Nov 2007
Posts: 72
Yep!
HOWIE BEDELL is offline   Reply With Quote
Old 04-25-2008, 03:47 PM   #4
Senior Member
 
Join Date: Aug 2006
Posts: 1,552
'nuff said.
__________________

Hokiehall is offline   Reply With Quote
Old 04-26-2008, 06:14 AM   #5
Site Team
 
KyDan's Avatar
 
Join Date: Mar 2008
Location: Louisville, KY
Posts: 8,368
I've got my replacement unit sitting right here.
I'll be installing it later today and trying it out.
(fingers, toes and eyes firmly crossed!!!!!!!!!!)
__________________
Peace!
Dan & Rita D
2017 Nissan Titan 5.6L King cab 4wd
1999 Suzuki Intruder Motorcycle
Blue Ox WD hitch

Camping days 2010-53, 2011-47, 2012-41, 2013-41, 2014-31, 2015-40, 2016-44, 2017-63, 2018-75, 2019-32
KyDan is offline   Reply With Quote
Old 04-30-2008, 05:11 AM   #6
Site Team
 
KyDan's Avatar
 
Join Date: Mar 2008
Location: Louisville, KY
Posts: 8,368
Well I installed my replacement Concertone.
The original had terrible hum in surround sound mode.
It also had high volume even on volume level 1.
The replacement has hiss all the time in all modes.
It hisses on CDs, FM and DVD play.
ARGH!!!!!!!

You'd think that Forest River would realize they are making a LOT
of customers mad with this crappy sound system!!
I know it is the single reason we are unsatisfied with our purchase.....
__________________
Peace!
Dan & Rita D
2017 Nissan Titan 5.6L King cab 4wd
1999 Suzuki Intruder Motorcycle
Blue Ox WD hitch

Camping days 2010-53, 2011-47, 2012-41, 2013-41, 2014-31, 2015-40, 2016-44, 2017-63, 2018-75, 2019-32
KyDan is offline   Reply With Quote
Old 04-30-2008, 06:18 AM   #7
Senior Member
 
Join Date: Jul 2007
Posts: 168
Angry

i swapped 12 times if i remeber correctly. it was at least 11 times. keep after them. mine is working fine. they need to come good on all this trouble. it is very frustrating to have a brand new unit and the entertainment not work. i am a gm mechanic and if you could not use the radio in your car we would be shot. people get very upset if a car breaks down and cannot be fixed with in a day or so but it took me 7 months to get a good radio for the trailer. is this acceptable?? i feel for you .
skidoonut is offline   Reply With Quote
Old 04-30-2008, 07:34 AM   #8
Senior Member
 
Join Date: Sep 2007
Posts: 3,260
I have a 2006, and the only problem I had is that there is no tone control, but mine did not come with a TV, DVD player or surround sound system. After reading all the problems that were posted and my warranty was up, I did away with it and as some of you know I made a mod to the entertainment center. As soon as I come with a plan on how to pull the wires I am going to install a Bose system.
rockwood06 is offline   Reply With Quote
Old 04-30-2008, 11:49 AM   #9
Member
 
Join Date: Jan 2008
Posts: 74
In our 2009 All American there is a Magna??? something or other, and we get a local AM station on all bands at a relatively high volume. When we crank the volume and drown it out the unit it sounds generally good but you can't talk to each other.

The factory warranty manager has approved its replacement. No I just have to get Camping World (not the dealer we purchased from) to order and install the new unit.
out4stlhed is offline   Reply With Quote
Old 04-30-2008, 01:36 PM   #10
Senior Member
 
Join Date: Mar 2008
Location: Jacksonville Florida
Posts: 1,264
I just had my concertcrap replaced yesterday at my dealer, my surround sound channel "A" main cabin area speakers died, and only the sub worked. It also made a noise like a single piano key strike of a low base note about every20 seconds. VERY irritating. The new concertcrap ZX 600 surround works fine, but the sub won't work when playing a DVD!!! It works everywhere else, however. AND the low piano note sound is still there. I'm wondering if it's the WFCO converter making the sound. I am going to check it out under battery power. What a pile of ----! Randy
__________________
/SIGPIC]'08 V-lite Flagstaff 30WRLS
'06 Ram 1500 QC hemi Reese dual cam sway control,
K&N series 77 intake, Hellwig helper spgs. LT tires,
Flowmaster "true duals", 380 h.p., Bilstein shocks
08flagvlite is offline   Reply With Quote
Old 04-30-2008, 01:47 PM   #11
Senior Member
 
Rockinwood's Avatar
 
Join Date: Oct 2007
Location: Central California
Posts: 277
Quote:
Originally Posted by Hokiehall View Post
'nuff said.
Ditto!!!!
__________________
2007 Rockwood 8317ss Reese Dual cam sway, 2002 Ford Excursion XLT V10,Prodigy Brake controller
Married DW 03/15/97 3 kids
Rockinwood is offline   Reply With Quote
Old 04-30-2008, 09:58 PM   #12
Member
 
gillguy's Avatar
 
Join Date: Mar 2008
Posts: 33
I'm on my third Concertone CRAP
So far the third times been a charm, but I've only used it once since I put it in, but I'll keep my fingers crossed every time I turn it on or put a DVD in. At least this one is supposed to be the newest model, hopefully it'll last. If the combo box (AM/FM/DVD) goes out that'll be fine because now I have a flat panel TV instead of the old Concertone monitor, so I could just add a DVD player and be set. Don't really need the AM/FM/Weather thing anyway.
As for my Rockwood I've been pleased but if/when we get a new TT it want be a Rockwood with a Concertone in it.
__________________
Bobby (USAF Retired)
2007 Chevy 2500 LBZ Duramax C/C, S/B 4X4
2006 Rockwood 8317SS
1973 Airstream Ambassador
Old Town Penobscot 16
gillguy is offline   Reply With Quote
Old 05-06-2008, 10:12 PM   #13
Senior Member
 
Join Date: Mar 2008
Posts: 279
Just a thought on the concert tone. I just got my 8317ss and was worried the unit ws going to have the same issues I read on here so I spent time checking it out. DVD's were fine, played good no hiss or feedback. Radio and CD's worked well to. XM, I haven't figured out which mode the unit has to be on to play the XM. Then I used the regular TV and PRESTO hum and feedback galore!! I was mad at first but then played around with the TV and found that both the concert tone and the TV control the volume... The TV volume was set too low and caused the hiss in the back gound. As soon as I brought the TV volume up to half way it was fine. So something to check if you find your issues are only with the TV.
vrunner is offline   Reply With Quote
Old 05-09-2008, 10:32 AM   #14
Member
 
Join Date: Nov 2007
Posts: 72
1st Trip

My Dealer Sent Me A Replacement Unit-concertone Z600.
I Installed It In About 5 Minutes.it Played Then Went Blank Like The First One.i Then Wiggled The Plug For The Power And It Powered Up Again.then I Hooked The Power Up The Old Unit That I Thought Was Broken And It Powered Up Also. As It Turnes Out There Was Nothing Wrong With The Unit.the Issue Is With The Plug On The Trailer Side.i Also Found An Over Tightened Wire Nut That May Have Contributed To The Problem.now Waiting For The Dealer To Call Me Back So I Can Fix This As To Not Void Any Warranty.
HOWIE BEDELL is offline   Reply With Quote
Old 05-14-2008, 07:47 AM   #15
Junior Member
 
Join Date: May 2008
Location: Plymouth, MI
Posts: 5
Had My concertone replaced on our rockwood 8317ss 2008 bought in October of last year. Replaced zx500 w/ zx600. It was replaced because dvd, and b a nd c channels wouldn't work. Now after I ( not the dealer ) hooked up the video cable to concertone, everything works. Now w/ the new unit I have to change channels w/ tv remote then change channels on concertone. Is this normal? (or just a pain...)Also found new unit has a zx550 sticker on the back.
dagoracing is offline   Reply With Quote
Old 05-14-2008, 09:22 AM   #16
Member
 
Join Date: Nov 2007
Posts: 72
I Dont Think So But I Will Check And Let You Know Later.
HOWIE BEDELL is offline   Reply With Quote
Old 05-15-2008, 05:43 AM   #17
Site Team
 
KyDan's Avatar
 
Join Date: Mar 2008
Location: Louisville, KY
Posts: 8,368
My recent replacement also said 600 on the box but the unit
has a 550 sticker on the back.
It's also defective with hiss in all modes, FM CD DVD......
--sigh......
KyDan is offline   Reply With Quote
Old 05-15-2008, 07:36 AM   #18
Junior Member
 
Join Date: May 2008
Location: Plymouth, MI
Posts: 5
KyDAn, I don't hear any hissing at all. I did notice that the old unit(ZX500) was very loud w/ the volume set at #1, this unit (zx600) I can set it at 3 or4 and it wouldn't wake the kids at night.
__________________
2008 Rockwood 8317SS
1998 Dodge Ram Quad cab 5.9L 2wd
The wife and I, 2 kids(5 and 8), and 2 beagles.
dagoracing is offline   Reply With Quote
Old 05-21-2008, 06:53 AM   #19
Junior Member
 
Join Date: Apr 2008
Posts: 6
Hi all,

I just found this thread while searching for Concertone problems. I have a pretty new Rockwood 2605 (purchased last October). We've used it three times. I noticed that if the trailer is not on shore power, the TV stops working once the battery gets down to half capacity. When I hit the power button, it turns green for about three seconds and the screen goes a dark gray, then goes back to red and the screen is completely off again.

Is this normal? I'm hoping it's not, because it doesn't seem useful to have a TV that doesn't work for boondocking.

Thanks,

- Chris
__________________

chrispitude is offline   Reply With Quote
Reply

Tags
rockwood

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:07 PM.


×