Thread Tools Display Modes
Old 11-26-2011, 08:43 PM   #1
Junior Member
Join Date: Oct 2011
Location: Southern CA
Posts: 9
First trip in our 2012 Rockwood 3001W

We just returned after a six day trip to Mission Bay in San Diego. After reading the numerous problems encountered by many on this forum I really had no idea what to expect so I took along many additional tools.
I am very pleased to state that I only encountered one problem and that was a complete lack of 110 power upon hooking everything up. Glad to say it was user error as we forgot to turn on the main breaker in the electrical box. Other than that we encountered no problems while towing or during our stay. Actually, everything worked flawlessly including the inflatable bed which proved to be very comfortable. We thought it was more comfortable than the primary bed so we traded with the grand kids.
Hopefully everything will continue to function without problems.

Rambler is offline   Reply With Quote
Old 11-26-2011, 09:46 PM   #2
Senior Member
jtstromsburg's Avatar
Join Date: Jul 2011
Location: Stromsburg, Nebraska
Posts: 1,578
Glad you had a great time! It's great to hear of problemless trips instead of our normal problems. enjoy it all!

Joel and Teresa
2016 Sabre 34TBOK
2006 GMC 3500 CC LB DRW 4X4
jtstromsburg is offline   Reply With Quote
Old 11-26-2011, 09:49 PM   #3
Site Team
Terier's Avatar
Join Date: Mar 2011
Posts: 8,751
On my first two trips in my unit I encountered the same microwave problem whick turned out to be "user error" too so I can relate.

Do you have any other trips planned? The weather was great today and suppose to be 83 tomorrow - wished I was out camping right now.

I just noticed that we live in the same general area (IE). Do you mind telling me about the campground in SD?
Great choice for "Living within my means" and camping for one...

2011 Salem Cruise Lite 20RBXL & 2011 Toyota Tundra Dbl Cab
Camping History: 45 Trips / 133 Nights / 3736 Miles
FRF Social Group: Campers of the West
Terier is offline   Reply With Quote
Old 11-27-2011, 12:46 AM   #4
Junior Member
Join Date: Oct 2011
Location: Southern CA
Posts: 9
It is "Campland on the Bay" which is right on the water of Mission Bay. About 2.5 miles from Sea World. Very nice place.
Rambler is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:14 AM.