Thread Tools Display Modes
Old 08-14-2011, 08:08 PM   #1
rossandjan's Avatar
Join Date: Apr 2011
Location: Zellwood, FL
Posts: 44
First Weekend out in new camper

We took our new Ultra Signature Lite out this weekend for a test run and overall everything worked great. It was too hot! Loved the set up and got everything put into place where we wanted it.

We could not get the Genesis Radio setup. We were able to watch tv and use the surround sound. I could not get the bass etc or the equilizer turned on. When I hit the setup button it just turned off. Also tried to hook up our video camero using the connector plate under the tv but it would not work. There is a spot for games and 2 others. Any ideas?
2012 Rockwood 8314BSS
2006 Chevy 2500 HD 6.0 gas 4x4
Ross - Letter Carrier (retired 2011), Jan - YNC(retired 1996)
Nights Camped 2011 (8)
rossandjan is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:39 AM.