Thread Tools Display Modes
Old 08-29-2015, 07:24 AM   #1
Senior Member
Blaster 84's Avatar
Join Date: Apr 2013
Posts: 204
Lost lighting in slide.

I have lost electrical power to the light fixtures on my slide. I found that the wire feeding the slide has completely pulled out of the channel it was in. Has anyone had experience rerunning a new wire to the slide?
From what I can determine it looks as if the wire ran in a metal channel that runs between the floor of the slide and the bottom side of the slide. The problem is accessing that end of the metal channel.
Terry and Carol
Daytona Beach, FL
2013 F150 XLT, SuperCab, Ecoboost
2010 Rockwood 8285WS
Nights camped:
2014 - 57; 2015 - 91; 2016 - 171
Blaster 84 is offline   Reply With Quote

light, slide

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:21 PM.