Thread Tools Display Modes
Old 09-09-2011, 06:54 AM   #1
Junior Member
Join Date: Jun 2010
Location: North Branch, MI
Posts: 25
Rockwood 8281SS Furnace Help Needed!!!

Hello all. Need some help. Set up at campground last night and had to fire up furnace. Nothing. When i slide the t-stat above room temp. I hear a little click in the t-stat and in the furnace but the blower does not come on. I verified the gas is on with stove operation and fridge operation while towing. No blown fuses for breakers. This is a 2011 camper. Any ideas? Wife and kids will be here toight and no furnace is not going to be fun. Thank you for any advice!

4Rasnicks is offline   Reply With Quote
Old 09-09-2011, 07:06 AM   #2
Senior Member
Join Date: Jul 2010
Location: Waynesville
Posts: 9,541
Did the dealer turn it on when you picked it up? If not try to turn it on agin,even with purging the other users of propane they somtimes have air in the feed line. Youroo!!

youroo is online now   Reply With Quote
Old 09-09-2011, 08:23 AM   #3
Junior Member
Join Date: Jun 2010
Location: North Branch, MI
Posts: 25
We have used the camper saveral times this year. There has never been an issue with the furnace. All other propane devices work as intended. Thanks.
4Rasnicks is offline   Reply With Quote
Old 09-09-2011, 08:28 AM   #4
Senior Member
rbarrieau's Avatar
Join Date: Jul 2011
Location: New England
Posts: 131
stuck relay

t-stat should close the time delay relay in the furnace that will start the blower to develop air flow prior to the propane ignition sequence.
Sounds like the relay may be stuck open.. tap around tne back side of the unit might get it to close..
I had a problem with this relay stuck closed and the blower never turned off..
Also the power for this relay does not go thru the furnace fuse.. mine actually went thru the "REF" fuse. pulling this fuse got my blower to finally stop. look at all your fuses..
Rich + Lori -2006 salem 27BHSS/2004 Avalanche
4:10 rearend - Roxy the puppy when allowed.
41 Days camped in 2011 and counting.
rbarrieau is offline   Reply With Quote
Old 09-10-2011, 06:15 AM   #5
Senior Member
Danimal's Avatar
Join Date: Dec 2010
Location: Michigan
Posts: 146
i have the same unit but a 2011 and i used the heater for the first time and eveything was fine but the second time i got nothing, i could not figure it out so to the dealer it went and it turned out the blower motor burned up
i tell you i have had this cmper for all most a year and one thing after another is failing, now i have a short in the DC power some place and everthing always seem to work fine at the dealer but as soon as its home or at a campsite then the problems start

sorry to vent on your post


2005 Dodge Ram
2011 Rockwood 8281SS
Danimal is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:39 PM.