Reply
 
Thread Tools Display Modes
Old 03-17-2009, 02:26 PM   #21
CLASS "A" Senior Member
 
cfsoistman's Avatar
 
Join Date: Nov 2008
Location: Upperco, Maryland
Posts: 3,135
Quote:
Originally Posted by justthe5ofus View Post
We have a 2009 9317SS. The only problems we've had are minor. There was an issue with the heater, one small part needed to be replace or needed to be switched, can't remember which.

The other issue is with the cable connection. The cable was very fuzzy. Apparently this was a problem for many of the new Forest River models. There was a bad connector. We just got it back from the dealer, we have no idea whether it's fixed or not. Neither we not the dealer have a cable hookup. We'll find out when we take our first trip. Either that, or ask the neighbor if we can hook up a 100 foot cable to their house!
If you have an old VCR you could hook it to the cable connection, push play, and check the connector. Just an idea!

__________________

__________________

2007 Georgetown 370TS
aka - RAYNMKR

Driver: Charlie
Navigator: Sheri
cfsoistman is offline   Reply With Quote
Reply

Tags
rockwood

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:56 PM.