Reply
 
Thread Tools Display Modes
Old 09-03-2012, 03:38 PM   #1
Senior Member
 
wagon52's Avatar
 
Join Date: Mar 2012
Location: The land of pleasant living
Posts: 186
Slide on 8312SS won't slide out

Went out to get something out of the back of the camper today. Needed to put the slides out to get to it. The rear slide went right out but the front just made a clicking noise and no movement. Thought that maybe the battery didn't have enough juice to do the task, so I plugged it in to shore power and tried again. No dice. Anyone else have this problem or a possible fix? Either way I'm gonna call the dealer tomorrow.
__________________

__________________
2012 Rockwood Signature Ultra Lite 8312SS
2008 Rockwood Roo 21SS (History)
1981 Starcraft Galaxy 2108 (its gone)
1999 Dodge Durango (Retired TT)
2006 Dodge Ram 3500 Quad Cab 4x4
wagon52 is offline   Reply With Quote
Old 09-03-2012, 05:06 PM   #2
Site Team
 
KyDan's Avatar
 
Join Date: Mar 2008
Location: Louisville, KY
Posts: 6,713
Do you have a battery disconnect switch?? IF you leave your battery connected it will
run down in just a few days or a couple weeks. IF your battery is very low it won't run the slide even if it's plugged in. Leave it plugged in for a couple hours and try again.
If it works after a while you definitely need a battery disconnect switch so you aren't killing your battery every time you store the trailer. It won't last long that way.
All trailers should come with a disconnect switch. Most don't and you have to add it yourself. There are many threads here about them. Just search the site for battery switch and you'll find plenty of discussion.
Also read the FAQ here-- Why is my new battery dead?
__________________

__________________
Peace!
Dan & Rita D
2004 5.3L Silverado 1500 ext. cab 2WD
1999 Suzuki Intruder Motorcycle
Blue Ox WD hitch, AirLift load levelers

Camping days 2010-53, 2011-47, 2012-41,
2013-41, 2014-31, 2015-40, 2016-44, 2017-63
KyDan is offline   Reply With Quote
Old 09-03-2012, 05:32 PM   #3
Senior Member
 
wagon52's Avatar
 
Join Date: Mar 2012
Location: The land of pleasant living
Posts: 186
Quote:
Originally Posted by KyDan
Do you have a battery disconnect switch?? IF you leave your battery connected it will
run down in just a few days or a couple weeks. IF your battery is very low it won't run the slide even if it's plugged in. Leave it plugged in for a couple hours and try again.
If it works after a while you definitely need a battery disconnect switch so you aren't killing your battery every time you store the trailer. It won't last long that way.
All trailers should come with a disconnect switch. Most don't and you have to add it yourself. There are many threads here about them. Just search the site for battery switch and you'll find plenty of discussion.
Also read the FAQ here-- Why is my new battery dead?
Thanks for the info. I will check when I get home this evening since I left it plugged in. Yes mine has a cut off switch and it has been off since my last trip.
__________________
2012 Rockwood Signature Ultra Lite 8312SS
2008 Rockwood Roo 21SS (History)
1981 Starcraft Galaxy 2108 (its gone)
1999 Dodge Durango (Retired TT)
2006 Dodge Ram 3500 Quad Cab 4x4
wagon52 is offline   Reply With Quote
Old 09-03-2012, 11:39 PM   #4
Senior Member
 
wagon52's Avatar
 
Join Date: Mar 2012
Location: The land of pleasant living
Posts: 186
Still doesn't work after being plugged in for 10 hours.
__________________
2012 Rockwood Signature Ultra Lite 8312SS
2008 Rockwood Roo 21SS (History)
1981 Starcraft Galaxy 2108 (its gone)
1999 Dodge Durango (Retired TT)
2006 Dodge Ram 3500 Quad Cab 4x4
wagon52 is offline   Reply With Quote
Old 09-04-2012, 07:55 AM   #5
Site Team
 
KyDan's Avatar
 
Join Date: Mar 2008
Location: Louisville, KY
Posts: 6,713
Quote:
Originally Posted by wagon52 View Post
Still doesn't work after being plugged in for 10 hours.
Bummer!! Sounds like it's time to call the dealer.
Please let us know what you find out. We're always glad to hear
"the rest of the story".

Good Luck!
__________________
KyDan is offline   Reply With Quote
Old 09-04-2012, 12:58 PM   #6
Senior Member
 
wagon52's Avatar
 
Join Date: Mar 2012
Location: The land of pleasant living
Posts: 186
Well my saga with the best dealer service continues. Called my dealer today and was told they couldn't even look at it until October 9th. Told them I had a trip planned for September 21st and my slideout wouldn't work and the trailer is only 4 months old. I was told that they couldn't do anything because the RV show was coming up and all their technicians are going to be tied up with that. What a crock of sh!!!!! I mean I don't expect them to drop everything but c'mon!
__________________
2012 Rockwood Signature Ultra Lite 8312SS
2008 Rockwood Roo 21SS (History)
1981 Starcraft Galaxy 2108 (its gone)
1999 Dodge Durango (Retired TT)
2006 Dodge Ram 3500 Quad Cab 4x4
wagon52 is offline   Reply With Quote
Old 09-04-2012, 01:09 PM   #7
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,235
You could try to use manual handle to move as maybe just stuck. If it moves then try electric again??
__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is offline   Reply With Quote
Old 09-04-2012, 01:12 PM   #8
Senior Member
 
Road-King's Avatar
 
Join Date: Jul 2012
Location: TN
Posts: 645
Is your trailer level? The clicking sound may be your clutch on the slide mechanization. If not level it may be binding... Just a guess.
__________________
Russ & Kim
2014 Alpine 3600RS
2007 Dodge Ram 3500 5.9 4X4
2008 Harley Davidson Road King 105th Anniversary
(2011-5 bad year)(2012-40)(2013-45)(2014-23)
Road-King is offline   Reply With Quote
Old 09-04-2012, 01:14 PM   #9
Senior Member
 
wagon52's Avatar
 
Join Date: Mar 2012
Location: The land of pleasant living
Posts: 186
Quote:
Originally Posted by Road-King
Is your trailer level? The clicking sound may be your clutch on the slide mechanization. If not level it may be binding... Just a guess.
It's not completely level but it's parked the same place it's always been when not in use and have had no problems with it before. I'll try it though.
__________________
2012 Rockwood Signature Ultra Lite 8312SS
2008 Rockwood Roo 21SS (History)
1981 Starcraft Galaxy 2108 (its gone)
1999 Dodge Durango (Retired TT)
2006 Dodge Ram 3500 Quad Cab 4x4
wagon52 is offline   Reply With Quote
Old 09-04-2012, 01:19 PM   #10
Senior Member
 
wagon52's Avatar
 
Join Date: Mar 2012
Location: The land of pleasant living
Posts: 186
Quote:
Originally Posted by fonzie
You could try to use manual handle to move as maybe just stuck. If it moves then try electric again??
Would do that but I don't see a crank to do it manually. All I see is a crank to manually put down the stabilizers. That's my own dumb fault though.
__________________

__________________
2012 Rockwood Signature Ultra Lite 8312SS
2008 Rockwood Roo 21SS (History)
1981 Starcraft Galaxy 2108 (its gone)
1999 Dodge Durango (Retired TT)
2006 Dodge Ram 3500 Quad Cab 4x4
wagon52 is offline   Reply With Quote
Reply

Tags
8312ss

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:11 AM.