Reply
 
Thread Tools Display Modes
Old 02-17-2013, 07:59 PM   #11
phat phrog stunt crew
 
Join Date: Jul 2012
Location: bethalto il
Posts: 1,422
jealous here for your ability to camp in february. today and tomorrow temps in the 50's has me looking at campground sites, planning the first trip. nightly news predicting ice here thursday to bring me back to reality.

stupid weather guy
__________________

__________________
dwaynerz is offline   Reply With Quote
Old 02-17-2013, 08:15 PM   #12
Junior Member
 
Join Date: Jan 2013
Posts: 27
Wow, that diamond package looks great. Best of luck with it.
__________________

__________________
bobmart5705 is offline   Reply With Quote
Old 02-20-2013, 05:43 PM   #13
Junior Member
 
Join Date: Jan 2013
Posts: 27
Was wondering how you're trips went so far? Were there any issues that you noticed with the tt? Only asking because we have yet to use our's for the first time and was hoping for some suggestions.
__________________
bobmart5705 is offline   Reply With Quote
Old 02-20-2013, 07:37 PM   #14
Junior Member
 
Smitty65's Avatar
 
Join Date: Apr 2012
Posts: 15
Haven't taken ours out of the winterizing yet. I'm getting the itch for it. Looking like the middle of April. This is the first time I've winterized so I'm hoping for the best. I'll keep my fingers and toes crossed. We're expecting 3-5 inches in the next 2 days.
__________________
Smitty65 is offline   Reply With Quote
Old 02-21-2013, 08:44 PM   #15
Member
 
Tjburke7's Avatar
 
Join Date: Jan 2013
Posts: 30
We have done fine, only had one issue with the power tongue jack. Went to lower it and it just clicked like it was locked up, had power, tried using the manual crank it still wouldn't budge. Turned power off unplugged everything and it still stayed locked up, then it just started working after I left it alone.
Otherwise everything works great, tows well gets a little loose sometimes even with load distributor and sway control.
__________________
Tjburke7 is offline   Reply With Quote
Old 02-21-2013, 09:06 PM   #16
Junior Member
 
Smitty65's Avatar
 
Join Date: Apr 2012
Posts: 15
What do you mean when it gets loose? Do you have the anti-sway on your hitch as well? We do and i love it.
__________________
Smitty65 is offline   Reply With Quote
Old 02-22-2013, 11:51 AM   #17
Member
 
Tjburke7's Avatar
 
Join Date: Jan 2013
Posts: 30
Well it's like the sway control isn't working well to me, the trailer feels like it is moving side to side.
__________________
Tjburke7 is offline   Reply With Quote
Old 02-22-2013, 09:22 PM   #18
Junior Member
 
Smitty65's Avatar
 
Join Date: Apr 2012
Posts: 15
I felt the same when I first got my trailer. I found that durning different times I would crank down more on the anti-sway and other time it was too stiff. It's something you'll figure out as you drive in different conditions how much tension you'll need.
__________________
Smitty65 is offline   Reply With Quote
Old 02-22-2013, 09:23 PM   #19
Junior Member
 
Smitty65's Avatar
 
Join Date: Apr 2012
Posts: 15
Also never ever grease the anti-sway. Suppose to have friction, metal on metal.
__________________

__________________
Smitty65 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:34 PM.