Thread Tools Display Modes
Old 05-23-2014, 12:31 AM   #1
Junior Member
Join Date: Mar 2014
Posts: 8
new to the Forum with a 396V

i purchased the 396V in march and have made a few mod's i installed. i have installed the Solar panels with lots of issues due to the RV does not label the harness, they just install cables and route, i think is very bad workmanship starting with engineering and quality but was able to figure it out. now the main AC does not cool. need service. more to come as time shows issues....
rick11flor is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:24 PM.