Reply
 
Thread Tools Display Modes
Old 05-23-2014, 01:40 AM   #1
Junior Member
 
Join Date: Mar 2014
Posts: 8
Red face new to the Forum with a 396V

i purchased the 396V in march and have made a few mod's i installed. i have installed the Solar panels with lots of issues due to the RV does not label the harness, they just install cables and route, i think is very bad workmanship starting with engineering and quality but was able to figure it out. now the main AC does not cool. need service. more to come as time shows issues....
__________________

__________________
rick11flor is offline   Reply With Quote
Old 05-23-2014, 01:52 AM   #2
Junior Member
 
Join Date: Mar 2014
Posts: 8
Angry leak in the living room slide out

major leak at the slide out will have this looked at ASAP, but i dont have time right now hope it doesnt rain hard again anytime soon. had to buy a blower to dry the area. looks like the slide out is not square another quality not quantity issue.
__________________

__________________
rick11flor is offline   Reply With Quote
Old 05-23-2014, 05:40 AM   #3
Senior Member
 
Witch Doctor's Avatar
 
Join Date: Feb 2012
Location: Clarksville Va.
Posts: 7,615
Quote:
Originally Posted by rick11flor View Post
major leak at the slide out will have this looked at ASAP, but i dont have time right now hope it doesnt rain hard again anytime soon. had to buy a blower to dry the area. looks like the slide out is not square another quality not quantity issue.
You are going to find more little issues from not the greatest quality control. Keep a log of what you find and then take it in and get them done. It seems lately there is more and more of these problems. The A/C and slide not sealing and letting water in is something you should get repaired ASAP. Sometimes I found it better to take care of the little stuff myself. But yours I would be at the dealer asap. If you are on a trip, call either the dealer or FR and have them find a dealer close to you and get it repaired. I have found that most dealers will move you up if it is during a trip, so you can get on your way. Good luck it's just not a FR problem it is a whole industry problem no matter who it is made by.
__________________
Rockwood #8289 WS 2012
F250 6.0 / Husky 16k
With 4 point leveling system
Witch Doctor is online now   Reply With Quote
Old 05-23-2014, 07:28 PM   #4
Junior Member
 
Join Date: Mar 2014
Posts: 8
sad to say but true

today i was going to empty the tanks and to my amazement the tank was clogged but i needed to empty to continue on my quest got to vacate but there is something in the gate area that is holding the waste back. issue after issue
__________________
rick11flor is offline   Reply With Quote
Old 05-24-2014, 04:48 AM   #5
Senior Member
 
Witch Doctor's Avatar
 
Join Date: Feb 2012
Location: Clarksville Va.
Posts: 7,615
Quote:
Originally Posted by rick11flor View Post
today i was going to empty the tanks and to my amazement the tank was clogged but i needed to empty to continue on my quest got to vacate but there is something in the gate area that is holding the waste back. issue after issue
Your gate valve may be not opening all the way, or you could just have some TP caught. Try and due some back flushes, stick a hose with a nozzle in the drain and turn some water on to clean the line. Then do a black tank flush. I would close the black valve and fill the holding tank and then open and dump, see if that helps. You are having some real problems. Sorry to hear that, your unit was not cheap. You would and should not be having all this. As fast as they put these things together I'm not surprised at all. Mostly FR Q/C sucks. They will get it right but it might take 2 or 3 trips back in. I try and stay at the dealer and watch them. I do not just like dropping off my unit.....
__________________
Rockwood #8289 WS 2012
F250 6.0 / Husky 16k
With 4 point leveling system
Witch Doctor is online now   Reply With Quote
Old 06-01-2014, 11:09 PM   #6
Member
 
Join Date: Dec 2013
Location: east tn
Posts: 51
I took my 376V back to boat and Rv when bedroom slide quit on 3rd try along with a long list of other stuff. 4 weeks later went to pick up and Forrest river was billed for all the stuff I had on list but only the slide was fixed. All the other was the same as was. I gave up and fixed it my self. The keypad started to loose the readings on the numbers and I called Forrest river and told them I didn't want to take it back and what the dealer had done and they just sent me a new pad. Didn't seem to care that they got took for work not done just said I'm sorry to here that. Go figure. Now to the good side of story. Fixed all that little stuff . Added solar - inverter- two 34 group batterys- progressive surge protector and now have it like I want it. It takes time and more money but sometimes its the only way to get what you want. I don't believe there has been quality or control of it in years.
__________________

__________________
Kickingupmudd is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:18 PM.