Reply
 
Thread Tools Display Modes
Old 07-27-2014, 11:52 PM   #1
Junior Member
 
Join Date: Jul 2014
Posts: 6
Engine stumbling

We have just purchased a 2004 Lexington 255. It has a stumble which the dealership did not find. We drove it from Florida to NJ. The stumble at low speed got worse. My initial thought was injectors plugged, so I used techron injector cleaner with no results. Any ideas? The vehicle has 52000 miles on it.
__________________

__________________
Nhisday is offline   Reply With Quote
Old 07-28-2014, 05:38 PM   #2
Senior Member
 
tmhyer's Avatar
 
Join Date: Apr 2014
Posts: 299
Are there any trouble codes? My 2014 Ford V10 is not a smooth revving engine. Is that what you have?
__________________

__________________
tmhyer is offline   Reply With Quote
Old 07-28-2014, 07:25 PM   #3
Retired Ford Tech
 
Join Date: Feb 2013
Location: Full-Timer
Posts: 141
Is or did the check engine light come on. It is probably an ignition coil. The trouble code will start with PO3 with the number 1 thru 10 depending on if it's a V-8 or V-10. If the light came on, but not now, the PCM will store the code. The PO code I mentioned is for a cylinder misfire. Some Auto Parts stores or repair shops will scan the PCM for free. If it's not a misfire, let me know what other codes you retrieve. Have fun Rod
__________________
rvpezzano is offline   Reply With Quote
Old 08-03-2014, 12:24 AM   #4
Senior Member
 
ernest917's Avatar
 
Join Date: Jun 2011
Location: Woodville, Texas
Posts: 1,713
Plugged fuel filter????


Sent from my iPhone using Forest River Forums
__________________
ernest917 is online now   Reply With Quote
Old 08-14-2014, 04:30 PM   #5
Senior Member
 
kenandterry's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario, Canada
Posts: 1,328
From what I'm reading, it sounds like this problem is clearly with the performance of the Ford engine, and nothing from Forest River.

Your original posting mentioned you had been to a dealership, but I'm not sure what type.

My suggestion would be that you take it to an authorized Ford dealership. The engine compartment and working of the motor are not foreign to them and they would be the people to see for getting your trouble resolved.

IMHO
__________________

Ken and Terry
2010 Georgetown 330TS being pushed by our
2017 GMC Terrain toad (4 wheels down)
kenandterry is offline   Reply With Quote
Old 08-14-2014, 04:41 PM   #6
Member
 
sammonilla's Avatar
 
Join Date: May 2014
Location: Woodinville WA
Posts: 94
Sounds like a fuel pressure or delivery issue. ALso could be coils but you should have mis-fire codes with a flashing SES light is that was the case.
__________________
Scott Sammons
Woodinville Wa
GO SEAHAWKS!
2016 SILVERADO 2500HD 6.6 Duramax
2012 280BH Casscade
sammonilla is offline   Reply With Quote
Old 08-14-2014, 05:26 PM   #7
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Fuel filter issue?

TURBS

"SABRE OWNERS UNITED"
__________________
TURBS is offline   Reply With Quote
Old 08-14-2014, 10:19 PM   #8
Senior Member
 
Join Date: Apr 2012
Location: South Carolina
Posts: 1,254
Fuel filter should affect it more with heavy loads when need higher fuel flow not low speed.
__________________
RamblerGuy
2011 Sunseeker 3100
1997 Pathfinder Toad
RamblerGuy is offline   Reply With Quote
Old 08-14-2014, 10:35 PM   #9
Member
 
Join Date: Feb 2010
Posts: 89
Recent problem on Georgetown 374...turned out to be bad coil which also compromised one spark plug....replaced both items...perfect!
__________________
ynott96 is offline   Reply With Quote
Old 08-14-2014, 10:40 PM   #10
Member
 
Join Date: Feb 2012
Location: Outside Boston Mass
Posts: 59
We often find moisture in the holes causing stumbling and missfires that are not serious enough to cause the SES or CEL to light. I did 8 plugs and coils in a 2006 5.4 and 8 plugs and coils in a 2004 4.6 last sunday for this exact issue. the 4.6 did pull a stored code but not the 5.4
__________________

__________________
2007 Cardinal 362bhle 5er
2006 f350 Diesel CC LB 4x4 4.10 locker lariat
1966 Mustang coupe...under construction
2004 Explorer 4.6 awd (16 year old daughters car)
2009 Mazda 6 (wife's ride)
Bunkfamily is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:03 AM.