Thread Tools Display Modes
Old 10-22-2012, 09:32 AM   #1
Junior Member
Join Date: Oct 2012
Posts: 2
Air Conditioner Problem on WP 18LT

I have a WP 18LT and am having issues with the AC. When I first turn it on it usually works for a little while and then it seems to "bog" down. The air is cold but it runs VERY slowly and you cant tell the difference between low and high. Has anyone else expirenced this problem?

dmblack is offline   Reply With Quote
Old 11-04-2012, 07:33 PM   #2
Junior Member
ford-hd's Avatar
Join Date: Sep 2011
Posts: 16
I kind of have the same issue. If I have my temp set real low (below70) it seems to kick down to low and run. After a few minutes I will hear it kick up to high. My thermostat is set to Auto. I notice it will shut off at temp and run normally if I don't have it turned down to low. Usually around 71.
ford-hd is offline   Reply With Quote

air conditioner

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:18 AM.