Reply
 
Thread Tools Display Modes
Old 06-25-2013, 11:33 AM   #1
Junior Member
 
Join Date: Jun 2013
Posts: 3
Battery not charging

I have a 2011 shamrock hybrid 19ft and the battery is dead and not charging! Does anybody have any ideas how to fix this?
__________________

__________________
Sidney41 is offline   Reply With Quote
Old 06-25-2013, 11:35 AM   #2
Junior Member
 
Join Date: Jun 2013
Posts: 3
I also put a new battery in and it did not work! Is this a wiring issue?
__________________

__________________
Sidney41 is offline   Reply With Quote
Old 06-25-2013, 11:35 AM   #3
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by Sidney41 View Post
I have a 2011 shamrock hybrid 19ft and the battery is dead and not charging! Does anybody have any ideas how to fix this?
Sounds like you need to do some troubleshooting.

You also need to remove battery and charge it back up to full and have it tested.

Do you have a wfco converter/ distribution panel

Do you have a digital multi meter?


Welcome to the forum
Turbs
__________________
TURBS is offline   Reply With Quote
Old 06-25-2013, 08:50 PM   #4
Senior Member
 
Stormrider151's Avatar
 
Join Date: Sep 2011
Location: South East
Posts: 915
I had the same problem while towing. Come to find out the hot wire from the truck was dead. It was a new truck and there were two fuses in the glove box that needed to be installed. Works great now.
__________________
Retired Fire Dept Battalion Chief
2016 Ever-Lite 232RBS
2012 F150 FX4 W/Max tow & Ecoboost

Getting old ain't for wimps!!!
Stormrider151 is offline   Reply With Quote
Old 06-25-2013, 10:12 PM   #5
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
You'll need to provide more information. Is any of the 12V lights/devices working when on shorepower? Do you have a battery disconnect switch? Have you checked for a blown in-line fuse or tripped in-line circuit breaker on the +ve wire from the battery?

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 07-10-2013, 01:04 AM   #6
Junior Member
 
Join Date: Jun 2013
Posts: 3
I have a fully charged battery and it will not power anything-power works when the camper is plugged in-tonite i checked the wiring underneath and all looks good-cu it be something else like the emergency brake circuit not working and hence not allowing power to draw into the camper?
__________________
Sidney41 is offline   Reply With Quote
Old 07-10-2013, 03:41 AM   #7
Moderators' Assistant
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 13,286
look for the infamous silver resettable breaker/fuse. it's along the A-frame, between the battery and the front of the trailer.
there's a little black reset button on it.

when someone installs the battery and crosses the battery wires, it sets this breaker/fuse off.

just Google "resettable 12v breaker/fuse" if you want a pic of one.
__________________
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH and Prodigy BC
bikendan is offline   Reply With Quote
Old 07-10-2013, 07:52 AM   #8
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
This

Name:   mM-R9PMEIf4ylCyRCIcGt2g.jpeg
Views: 831
Size:  10.9 KB
__________________
TURBS is offline   Reply With Quote
Old 09-06-2013, 07:29 PM   #9
Junior Member
 
Join Date: Jun 2011
Posts: 11
I had the problem of the battery not charging and even with the 23SS plugged in I had to connect a power pack or battery charger to get the slide to work. Three times the dealer checked and told me that everything was OK. It wasn't. When I looked for the "infamous resettable fuse" I found that one of the terminal nuts was missing, one wire was completely off and a second was probably making intermittent contact. Put the wires back on the terminal replaced the missing nut and had no problems since!
__________________

__________________
Robin and Gloria Vinson
Montreal, QC, Canada
2010 F-150 SuperCrew XLT 4x4
2012 Shamrock 23SS
47leaf is offline   Reply With Quote
Reply

Tags
expandable, hybrid, shamrock

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:49 AM.