Thread Tools Display Modes
Old 07-11-2011, 06:23 PM   #1
Join Date: Feb 2011
Posts: 59
Electrical issues

Inane a Roo19 and I am experiencing the weirdest electrical issue. The outlet next to the door on the triangular cabinet is out. All other outlets work. The front light but the tongue will not turn on and the radio will not turn on. All fuses are ok and the Ground fault is set properly on the bathroom outlet. Any suggestions on the problem? Thanks.

southpaw821 is offline   Reply With Quote
Old 07-11-2011, 06:35 PM   #2
Senior Member
Boyd's Avatar
Join Date: Aug 2010
Location: Iron River, MI
Posts: 372
Is it possible that all three problems are on one line? If so, it sounds as if a wire has come loose. Good luck.
"If everything seems to be going well, look around, you've obviously overlooked something."
Boyd is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:35 AM.