Reply
 
Thread Tools Display Modes
Old 08-16-2014, 07:00 PM   #1
Senior Member
 
urocav2001's Avatar
 
Join Date: Mar 2013
Posts: 560
Gfi outlet

Ok so my gfi outlet tripped today, I had all three heated mattresses plugged in and a radio controlled battery charger plugged in outside, nothing got wet, no fuses look blown or no breakers are tripped, I unplugged everything and it still won't reset... Any other suggestions?


Sent from my iPhone using Forest River Forums
__________________

__________________
urocav2001 is offline   Reply With Quote
Old 08-16-2014, 09:04 PM   #2
Senior Member
 
urocav2001's Avatar
 
Join Date: Mar 2013
Posts: 560
Also noticed all of the gfi outlets don't work? I am assuming the gfi itself is bad. One outlet works near the converter box which is a non gfi outlet.


Sent from my iPhone using Forest River Forums
__________________

__________________
urocav2001 is offline   Reply With Quote
Old 08-16-2014, 09:10 PM   #3
Senior Member
 
Join Date: Feb 2014
Location: Long Island
Posts: 519
Try turning each breaker fully off then back on. Sometimes that solves the problem.


Started Out With Nothing,
Still Have Most Of It Left!
__________________
jwedell is offline   Reply With Quote
Old 08-16-2014, 09:29 PM   #4
Senior Member
 
urocav2001's Avatar
 
Join Date: Mar 2013
Posts: 560
Tried that no luck :/


Sent from my iPhone using Forest River Forums
__________________
urocav2001 is offline   Reply With Quote
Old 08-16-2014, 09:51 PM   #5
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Quote:
Originally Posted by urocav2001 View Post
Tried that no luck :/


Sent from my iPhone using Forest River Forums
More than likely the GFI is defective. They are the most likely of all outlets to quit. The reg outlets downstream are regular outlets fed by the GFCI. Check before shopping, most RV use a shallow style box and outlet and standard shoreside units won't fit. Replacements are inexpensive.
__________________
VinceU is offline   Reply With Quote
Old 08-17-2014, 09:16 AM   #6
Senior Member
 
urocav2001's Avatar
 
Join Date: Mar 2013
Posts: 560
Ok thanks


Sent from my iPhone using Forest River Forums
__________________
urocav2001 is offline   Reply With Quote
Old 08-17-2014, 11:21 AM   #7
Senior Member
 
urocav2001's Avatar
 
Join Date: Mar 2013
Posts: 560
Yup bad gfi outlet, all fixed now


Sent from my iPhone using Forest River Forums
__________________

__________________
urocav2001 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:31 AM.