Reply
 
Thread Tools Display Modes
Old 09-25-2015, 09:18 PM   #1
Senior Member
 
Marines0811's Avatar
 
Join Date: Sep 2011
Location: Owatonna MN
Posts: 248
Help!!

Camping without power and my battery doesn't work no power to the camper. Power jack and light on it work. But nothing to.the converter. I checked all fuses and are good even one up front by the battery. Have a generator but don't want to run it at night. It's not a quite one. Everything works when the gen is running.
__________________

__________________
Marines0811 is offline   Reply With Quote
Old 09-25-2015, 09:29 PM   #2
Senior Member
 
Blackhat6mike's Avatar
 
Join Date: Dec 2014
Location: St Simons Island, GA
Posts: 1,204
How many batts do you have?
__________________

__________________
Aviator Wright Flyer #1919
Army Pathfinder Vietnam, 3 tours
DAV, MOPH, VFW, NRA, 1stCav. ABN
Blackhat6mike is offline   Reply With Quote
Old 09-25-2015, 09:30 PM   #3
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
There is another current limiter you should check. It is located near the metal umbilical junction box. The current limiter has a reset button on the short side.

Looks like below:
Attached Thumbnails
Click image for larger version

Name:	30407-20.jpg
Views:	90
Size:	32.2 KB
ID:	89860   Click image for larger version

Name:	360426586.jpg
Views:	81
Size:	57.9 KB
ID:	89861  
Attached Images
 
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 09-25-2015, 09:32 PM   #4
Senior Member
 
Marines0811's Avatar
 
Join Date: Sep 2011
Location: Owatonna MN
Posts: 248
Thanks , eating in town now. I will check.when we get back.
__________________
Marines0811 is offline   Reply With Quote
Old 09-25-2015, 10:15 PM   #5
Senior Member
 
Join Date: Jul 2015
Posts: 150
That current limiter switch looks like what was the problem when I had similar symptoms a few weeks ago. In particular the 3rd picture. It was mounted on the inside of the driver side of the frame just as it passes under the front of the trailer body. I had to push (or rather the dealer service rep pushed) the little button on the short side as Herk7769 points out. Apparently it can some times trigger when plugging into the TV or other things.
__________________
drhroo is offline   Reply With Quote
Old 09-25-2015, 10:20 PM   #6
Senior Member
 
deartruc's Avatar
 
Join Date: Sep 2014
Location: Southern New England
Posts: 818
yup. Happened in my pdi. Batt voltage ran low so current was driven up.
__________________
2008 Dodge Durango
2015 Roo 23 ikss
deartruc is offline   Reply With Quote
Old 09-28-2015, 12:46 PM   #7
Senior Member
 
Marines0811's Avatar
 
Join Date: Sep 2011
Location: Owatonna MN
Posts: 248
Was exactly that switch. You guy are a life saver. That's what I love about this group. People always willing to help. The weekend was a success that's to you guys.
__________________
Marines0811 is offline   Reply With Quote
Old 09-28-2015, 12:49 PM   #8
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
Glad we could help.
__________________

__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:57 AM.