Reply
 
Thread Tools Display Modes
Old 06-11-2015, 11:12 AM   #1
Member
 
Join Date: Jul 2014
Posts: 36
Movie will not play on tv

Hi everyone, I need help. I have a shamrock camper with a genesis stereo deck. I want to play movies. I have 3 wall outlets. I assume one for roof antenna and one for cable. The other, I'm not sure (coax will not screw into that one). I can hear the movie playing thru the camper speakers, but I get no picture. I have cycled thru all the tv settings and still nothing. Can anyone out there help?
__________________

__________________
jscraig is offline   Reply With Quote
Old 06-11-2015, 11:23 AM   #2
Senior Member
 
urocav2001's Avatar
 
Join Date: Mar 2013
Posts: 560
Is the yellow av cable plugged in?


Sent from my iPhone using Forest River Forums
__________________

__________________
urocav2001 is offline   Reply With Quote
Old 06-11-2015, 11:36 AM   #3
Member
 
Join Date: Jul 2014
Posts: 36
No. I don't see anywhere to plug one in on the deck.
__________________
jscraig is offline   Reply With Quote
Old 06-11-2015, 12:06 PM   #4
Senior Member
 
urocav2001's Avatar
 
Join Date: Mar 2013
Posts: 560
On my 13 there is a yellow plug that plugs in to a av port on the side right behind tv


Sent from my iPhone using Forest River Forums
__________________
urocav2001 is offline   Reply With Quote
Old 06-11-2015, 12:06 PM   #5
Senior Member
 
urocav2001's Avatar
 
Join Date: Mar 2013
Posts: 560
I'll post a pic when I get home in about an hour


Sent from my iPhone using Forest River Forums
__________________
urocav2001 is offline   Reply With Quote
Old 06-11-2015, 12:12 PM   #6
Senior Member
 
Jimandchris's Avatar
 
Join Date: Aug 2013
Location: Southeast Michigan
Posts: 586
Hi, there should be a video and audio cable coming from the genisis player to the rear of the tv. Ours is coming thru a separate panel located above the tv mount. Perhaps they are not connected?
Attached Thumbnails
Click image for larger version

Name:	1434039031961.jpg
Views:	104
Size:	72.7 KB
ID:	79626  
__________________
2014 Roo 23SS
2013 GM Sierra CC
Prodigy P3 Brake Controller
Equal-i-zer Hitch
Nites Camped 2016 -25
Jimandchris is offline   Reply With Quote
Old 06-11-2015, 12:49 PM   #7
Senior Member
 
urocav2001's Avatar
 
Join Date: Mar 2013
Posts: 560
Mine looks like this Click image for larger version

Name:	ImageUploadedByForest River Forums1434041375.377421.jpg
Views:	101
Size:	50.3 KB
ID:	79629Click image for larger version

Name:	ImageUploadedByForest River Forums1434041388.150038.jpg
Views:	101
Size:	53.0 KB
ID:	79632


Sent from my iPhone using Forest River Forums
__________________
urocav2001 is offline   Reply With Quote
Old 06-11-2015, 01:46 PM   #8
Senior Member
 
Join Date: Jun 2014
Posts: 301
Quote:
Originally Posted by jscraig View Post
Hi everyone, I need help. I have a shamrock camper with a genesis stereo deck. I want to play movies. I have 3 wall outlets. I assume one for roof antenna and one for cable. The other, I'm not sure (coax will not screw into that one). I can hear the movie playing thru the camper speakers, but I get no picture. I have cycled thru all the tv settings and still nothing. Can anyone out there help?
Ours you play through the radio you to go to n menu and select the input av1 is radio av2 is the cd player (video player)
__________________
Myrle is offline   Reply With Quote
Old 06-17-2015, 12:42 PM   #9
Junior Member
 
Join Date: Jun 2015
Posts: 9
My player was hooked wrong from the factory, did the same thing. Took out the stero changed point of connection and problem solved
__________________
time2fury is offline   Reply With Quote
Old 06-25-2015, 11:44 PM   #10
Senior Member
 
Join Date: Apr 2015
Location: Minnesota
Posts: 131
Hi jscraig,
I had the EXACT same problem in our 2014 Sabre with the Genesis system. I ended up pulling my Genesis system off the wall and found that the HDMI cable from the back of the Genesis was not plugged in. The HDMI cable runs from the Genesis down to the TV HDMI input. You need to check that for sure. If you have voice/audio I think this is the problem. Let us know.
__________________

__________________
JoeNanMinn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:00 PM.