Reply
 
Thread Tools Display Modes
Old 07-01-2015, 08:28 PM   #1
Member
 
husky family's Avatar
 
Join Date: Feb 2014
Location: Chicago Suburb
Posts: 63
No power to outlets

Hi everyone. I have a 2014 Roo 233s and started packing it up for a weekend trip. Plugged into shore power, but no power to my outlets. All else seems to be working. Fridge, a/c, microwave, etc. All breakers good, all fuses good. Even checked fuse and breaker under the camper. What am I missing??
__________________

__________________

2014 Rockwood Roo 233s
2014 Runaway Navigator
2013 GMC Yukon XL
Nights camped in 2017 Only 11 - so far
Nights camped in 2016 32
husky family is offline   Reply With Quote
Old 07-01-2015, 08:36 PM   #2
Junior Member
 
nvychf's Avatar
 
Join Date: Jun 2015
Posts: 16
I would double check your fuses and breakers. I just purchased a 2015 233S, I pick it up Friday. But I do know that our breaker panel under the frig has small LEDs that light up when the fuse is bad, I would check there again.
__________________

__________________
nvychf is offline   Reply With Quote
Old 07-01-2015, 08:39 PM   #3
Senior Member
 
crunchman12001's Avatar
 
Join Date: Feb 2013
Location: Chagrin Falls, Ohio
Posts: 3,077
Check to see if you tripped a GFI inside.
crunchman
__________________
2017 Salem Villa Estate 395RET-
2011 Coachmen Freedom Express 295RLDS- Sold
2015 F-250 FX4
crunchman12001 is offline   Reply With Quote
Old 07-01-2015, 08:40 PM   #4
Senior Member
 
Join Date: Jun 2012
Posts: 6,745
Quote:
But I do know that our breaker panel under the frig has small LEDs that light up when the fuse is bad, I would check there again.
The fuses are for 12VDC circuits. I'm assuming the posters issues are with his 110VAC outlets, since the other things he says are working are 110VAC powered. So his issue would be with the circuit breakers.

He needs to check the GFCI in his bathroom. If the GFCI trips, it also kills power in many of the other 110VAC outlets.
__________________
1988 Coleman Sequoia - popup (1987-2009) - outlasted 3 Dodge Grand Caravans!
2012 Roo19 - hybrid (2012-2015)

2016 Mini Lite 2503S - tt (2015 - ???)
2011 Traverse LT, 3.6L, FWD
2009 Silverado 1500 Ext Cab, 5.3L, 4x4, 3.73
2016 Silverado 2500HD Dbl Cab, 6.0L 4x4, 4.10
rockfordroo is online now   Reply With Quote
Old 07-01-2015, 08:49 PM   #5
Member
 
husky family's Avatar
 
Join Date: Feb 2014
Location: Chicago Suburb
Posts: 63
Thanks guys. It was the GFCI outlet tripped. All good now.
__________________

2014 Rockwood Roo 233s
2014 Runaway Navigator
2013 GMC Yukon XL
Nights camped in 2017 Only 11 - so far
Nights camped in 2016 32
husky family is offline   Reply With Quote
Old 07-01-2015, 08:52 PM   #6
Senior Member
 
Join Date: Jul 2010
Location: Waynesville
Posts: 12,031
Quote:
Originally Posted by crunchman12001 View Post
Check to see if you tripped a GFI inside.
crunchman
I am in this corner also! Youroo!!
__________________
youroo is offline   Reply With Quote
Old 07-01-2015, 08:55 PM   #7
Mod free 5er
 
Join Date: Mar 2008
Location: Concord, NC
Posts: 24,215
Quote:
Originally Posted by husky family View Post
Thanks guys. It was the GFCI outlet tripped. All good now.
Suggest you go to Lowes/HD and buy new ones to replace the factory ones which are notoriously poor quality.
__________________
OldCoot is offline   Reply With Quote
Old 07-01-2015, 08:56 PM   #8
Senior Member
 
crunchman12001's Avatar
 
Join Date: Feb 2013
Location: Chagrin Falls, Ohio
Posts: 3,077
Quote:
Originally Posted by husky family View Post
Thanks guys. It was the GFCI outlet tripped. All good now.
Excellent, glad we got you going.
happy camping!
crunchman
__________________
2017 Salem Villa Estate 395RET-
2011 Coachmen Freedom Express 295RLDS- Sold
2015 F-250 FX4
crunchman12001 is offline   Reply With Quote
Old 07-01-2015, 09:06 PM   #9
Senior Member
 
VinceU's Avatar
 
Join Date: Dec 2011
Posts: 3,502
Quote:
Originally Posted by nvychf View Post
I would double check your fuses and breakers. I just purchased a 2015 233S, I pick it up Friday. But I do know that our breaker panel under the frig has small LEDs that light up when the fuse is bad, I would check there again.
The red Led light comes when a DC circuit opens. AC circuits all use the handle flip switch, half open is a trip indicator.
__________________
VinceU is offline   Reply With Quote
Old 07-01-2015, 09:15 PM   #10
Junior Member
 
nvychf's Avatar
 
Join Date: Jun 2015
Posts: 16
Good to know, did not think the GFCI would be daisy chained together. Thanks Crunch!
__________________

__________________
Just own it and you will be okay. Just own it.
nvychf is offline   Reply With Quote
Reply

Tags
power, electrical

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:41 PM.