Reply
 
Thread Tools Display Modes
Old 05-01-2012, 06:39 PM   #1
Junior Member
 
Namthor's Avatar
 
Join Date: May 2011
Posts: 25
Rockwood Roo 2011 23SS

My Radio is showing it has power but it will not turn on. Breaker, fuse and GFI are all good. I literally turned it off one evening and went to turn it back on the next morning with epic failure. Has anyone been through this? What was your resolution to the situation?
__________________

__________________
Namthor is offline   Reply With Quote
Old 05-01-2012, 07:01 PM   #2
Senior Member
 
TF-Kevin's Avatar
 
Join Date: May 2010
Location: Calgary Alberta Canada
Posts: 108
my radio in my shamrock 19 did not want to turn on, so i pulled the fuse and put it back in and it worked, the fuse at the fuse box or panel
__________________

__________________
Kevin & Debbie and our little dog Emma
2004 F-150 Lariat 4X4 Ext Cab 5.4
2010 Flagstaff Shamrock Hybrid 19
TF-Kevin is offline   Reply With Quote
Old 05-01-2012, 11:12 PM   #3
Moderator Emeritus
 
Triguy's Avatar
 
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,950
I had that problem Namthor. Tried the fuse-pulling with intermittent success and so took it in to the dealer. The radio was replaced under warranty.
__________________
Scott
DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 05-05-2012, 08:44 AM   #4
Junior Member
 
Namthor's Avatar
 
Join Date: May 2011
Posts: 25
Thanks for the info, i will give it a shot.
__________________
Namthor is offline   Reply With Quote
Old 05-05-2012, 02:26 PM   #5
Moderators' Assistant
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 13,286
Namthor, Bob Fields, the Concertone rep, will reply to a PM.

you could try that also. he's helped many on the forum.
__________________
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH and Prodigy BC
bikendan is online now   Reply With Quote
Old 05-11-2012, 07:49 PM   #6
Junior Member
 
Namthor's Avatar
 
Join Date: May 2011
Posts: 25
I pulled the fuse and replaced it. Resolved issue for last 4 days. Camping this weekend so far so good!
__________________

__________________
Namthor is offline   Reply With Quote
Reply

Tags
23ss

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:17 AM.