Thread Tools Display Modes
Old 10-15-2013, 04:11 PM   #11
tclcyl's Avatar
Join Date: Feb 2013
Location: South Georgia
Posts: 80
I had trouble with this too on my Shamrock 25RS. I carried it back to the dealer and he greased all the wheels under the slide and the rubber seals around the slide. He said it could have been from the slide dragging on the way back in because that was when it would blow. He put a resetting fuse on mine and I have had no more trouble with it!

27 total nights camped in 2013 year not including "camp driveway" and 3 so far this year!
tclcyl is offline   Reply With Quote

expandable, hybrid, shamrock

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:25 PM.