Thread Tools Display Modes
Old 06-07-2016, 03:08 PM   #1
Junior Member
Join Date: Apr 2016
Posts: 9
A/C Not Cooling Properly

Have a new 2016 Salem TT. On an 80ish degree day in the shade, my air set on cool to 74 degrees (thermostat; fan on auto, per instructions from the dealer). The air does not come out very cool and the A/C ran the entire day. On my old trailer, i could see the water draining off the roof from the A/C. Nothing on this one. Old trailer would cool it down really good.

If i changed the thermostat, the fan would kick off, sounded like the compressor kicked on and fan would come back on. No issue at night (did not run because trailer had cooled down).

Any advice on this one before taking back for a checkup by the dealer? Seen threads about checking the input/output temp but now sure how to do this (Accountant by trade ) or other checks I should do?

Thanks in advance.

chriscwilson is offline   Reply With Quote
Old 06-07-2016, 03:25 PM   #2
Head Rambler
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 3,280
Was the Quick Cool vent open when you checked it?

It's pretty easy to check the delta temp between the outlet and return if you have a regular or infrared thermometer. Just take a reading at the return grate and then one at the outlet grate with the quick cool vent open and subtract the outlet from the return temp. It should be about 15F.

You also should remove the grill and inspect the partition between the discharge and return. It should be sealed off and not leak air between the two.

Salem 29RKSS Pushing a 2500 Mega-Cab CTD!
Gotta go campin!
Bama Rambler is online now   Reply With Quote
Old 06-07-2016, 03:36 PM   #3
Junior Member
Join Date: Apr 2016
Posts: 9
I will check that. Thanks for the info. Good info on youtube as well.
chriscwilson is offline   Reply With Quote
Old 06-07-2016, 04:01 PM   #4
Phat Phrog Stunt Team
TURBS's Avatar
Join Date: Aug 2011
Location: Iowa
Posts: 34,205
Definitely check the divider!

I've had two forest river units with divider issues.

2015 Columbus 320RS
2008 2500HD Duramax
2015 nights camped "34"
2016 nights camped "10"
TURBS is online now   Reply With Quote
Old 06-16-2016, 08:14 AM   #5
Junior Member
Join Date: Apr 2016
Posts: 9
Checked out the input/output temp. No difference. Took it to the dealer. Compressor has power but does not kick on. Looks like I am getting a new AC unit.
chriscwilson is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:47 PM.