Thread Tools Display Modes
Old 05-22-2016, 06:08 PM   #1
Senior Member
FreddieMac's Avatar
Join Date: Aug 2014
Posts: 131
LP alarm

My LP alarm went off this weekend. It was on green light and one blinking read on the safe-t-alert.

I am told there are two possible problems, an actual leak or a battery not charging back up. My battery looked slightly low on water and I filled it up.

Trying to figure out if it is worth bringing in to the dealer for an LP test. Any thoughts?

FreddieMac is offline   Reply With Quote
Old 05-22-2016, 10:12 PM   #2
Moderators' Assistant
bikendan's Avatar
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 10,193
Test the battery with a hydrometer first.
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
'07 Roo 23SS pushing an '07 Chevy Avalanche
Equalizer WDH and Prodigy BC
bikendan is online now   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:05 AM.