Reply
 
Thread Tools Display Modes
Old 05-22-2016, 07:08 PM   #1
Senior Member
 
FreddieMac's Avatar
 
Join Date: Aug 2014
Posts: 95
LP alarm

My LP alarm went off this weekend. It was on green light and one blinking read on the safe-t-alert.

I am told there are two possible problems, an actual leak or a battery not charging back up. My battery looked slightly low on water and I filled it up.

Trying to figure out if it is worth bringing in to the dealer for an LP test. Any thoughts?
__________________

__________________
FreddieMac is offline   Reply With Quote
Old 05-22-2016, 11:12 PM   #2
Moderators' Assistant
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 13,281
Test the battery with a hydrometer first.
__________________
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH and Prodigy BC
bikendan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:07 PM.