Thread Tools Display Modes
Old 07-13-2016, 07:33 PM   #1
Junior Member
Join Date: Jul 2016
Location: Hollywood, MD
Posts: 3
Hello from Hollywood......MD!

Greetings folks!
I've been to all the posts of the Roo forum as we worked through the purchase of our 2011 Roo21SS. I'm an engineer and former mechanic and this girl has been sitting two years. For the next few weeks we'll be cleaning, repairing and bringing her back up to the condition she was in when she left the pouch. Have to do some work to the Mounty (our temp TV) to add a cooler and trans temp gauge. I'll have lots of questions I'm sure, and from reading all the posts you are a great bunch at sharing your experiences! To start I've two...
1) The fresh water tank looks like it has black mold growing on spots inside. It was winterized and full when we got it. Do you have a RVer fix for this other than either bleach or replacement? If replacement, any idea of the model # of the tank?

2) My 6500 watt generator trips when running her. I've read and confirmed that the 4 wire plugs only pull from one leg of the 240 volt circuit. Any thoughts on wiring the two legs in parallel?

I'll likely have dump station questions too so I don't look like a moron or take too much time, but will hold until I search some more.

Safe journeys Robin & Gina

RobinHood190 is offline   Reply With Quote
Old 07-13-2016, 08:42 PM   #2
Senior Member
buskirk21921's Avatar
Join Date: Sep 2010
Location: Elkton, MD
Posts: 503
Welcome from another Marylander(Elkton).
Attached Thumbnails
Click image for larger version

Name:	Md blue crabs.jpg
Views:	20
Size:	61.4 KB
ID:	114062  

Joe and Diane Buskirk
2015 Chevrolet Silverado 3500HD Duramax Diesel 4x4 SWD
2015 360IBL Coachmen 5th Wheel

"Camping is not just a past time it is my relaxing way of life"
buskirk21921 is offline   Reply With Quote
Old 07-14-2016, 08:19 AM   #3
Senior Member
Wiscampsin's Avatar
Join Date: Feb 2012
Location: Wisconsin
Posts: 8,140
Welcome from Wisconsin.
2013 Palomino Sabre 34REQS-6

Link to pics:
Wiscampsin is offline   Reply With Quote
Old 07-14-2016, 08:22 AM   #4
Senior Member
Join Date: Jan 2012
Posts: 1,607
Sorry but can't help but welcome from Delaware
dblr is offline   Reply With Quote
Old 07-14-2016, 08:33 AM   #5
Senior Member
Join Date: Feb 2016
Posts: 221
Sorry can't help with the ROO but welcome from Sykesville, MD!!

2016 Rockwood 2703WS Sapphire
2011 F150 Ecoboost SCAB/3.55
Martsing is offline   Reply With Quote
Old 07-14-2016, 08:41 AM   #6
Join Date: Dec 2013
Location: California Md
Posts: 38
Welcome from California Maryland As far as the tank I think I would put 2 or 3 cups of bleach in it fill it up about 3/4 drive around for awhile park it fill it with water the rest of the way, run all your faucets then let it set over night. I think that will take care of your mold problem inside the tank. Good luck
jjcook is offline   Reply With Quote
Old 07-14-2016, 12:19 PM   #7
Georgia Frog Rally 2017
aceinspp's Avatar
Join Date: Jun 2015
Location: GA
Posts: 7,253
Welcome to the forum. Does your gen have a 30amp plug? Would like to have a little more info on what you are doing with the gen. Later RJD
2015 35 FT V-Lite 30WRLIKS Diamond Package
2015 Chevy 2500 6.0 4:10 gearing.
Days camped in 2015--46
Days booked for 2016--60
Days camped in 2016 so far 51
aceinspp is online now   Reply With Quote
Old 07-14-2016, 01:10 PM   #8
Junior Member
Join Date: Jul 2016
Location: Hollywood, MD
Posts: 3
Aceinspp, I have a 120/240 30A plug. 4 wire. I want to tie the two 120 legs together in parallel and feed it to the hot leg of the 3 way plug. That should provide 120 at a full 30 Amps. I just wonder how the regulator on the generator will react....
RobinHood190 is offline   Reply With Quote
Old 07-17-2016, 10:27 AM   #9
Junior Member
Join Date: Jul 2016
Location: Hollywood, MD
Posts: 3
Fellow campers - thanks for the warm greetings!

Bleach fixed my mold problem and my generator's AVR is bad solving my Power connection questions.
Spent yesterday powerwashing and waxing...Glad I don't have a 5th wheel...
RobinHood190 is offline   Reply With Quote
Old 07-17-2016, 10:51 AM   #10
Senior Member
davel1971's Avatar
Join Date: Nov 2013
Location: Seaford, De
Posts: 2,131
you need to get an adapter that goes from the 4 wire gen outlet to a 3 wire 30 amp outlet

David & Lynn
2014 Coachmen Chaparral Signature 327 RLKS
2016 Ford F350 Lariat CC Dually
davel1971 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:54 PM.