Reply
 
Thread Tools Display Modes
Old 04-08-2014, 08:38 PM   #1
Junior Member
 
Join Date: Mar 2014
Posts: 2
Hello from NH

Just traded in our Coleman CT 260 for a Coachmen 320BHDS FREEDOM EXPRESS LE. Can't wait for the snow to melt.
__________________

__________________
amatsoniii is offline   Reply With Quote
Old 04-08-2014, 08:46 PM   #2
Senior Member
 
BamaBob's Avatar
 
Join Date: Nov 2013
Location: Whereever our Berkshire is Parked!
Posts: 6,987
Welcome to the Forums and to your new RV!!
__________________

__________________
Bob & Anne-Marie [BamaBob & 6 Actual]
| 2017 Berkshire XLT 43A with Ultrasteer Tag | Blue Ox Avail + KarGard II |
| SMI AF-1 Air Brake | 2016 Jeep Cherokee Overland TOAD | Pedego Bikes |
Nights Camped: 2013 - 24 2014 - 42 2015 - 56 Jul 2016 - Fulltime
BamaBob is offline   Reply With Quote
Old 04-08-2014, 08:52 PM   #3
Senior Member
 
Join Date: Dec 2013
Location: Crawfordville, Florida
Posts: 588
Congrats and welcome from sunny Florida
__________________
Jerry. Vietnam vet.
Retired
jgahlhoff is offline   Reply With Quote
Old 04-08-2014, 09:05 PM   #4
Senior Member
 
Join Date: Sep 2012
Location: Mass
Posts: 532
Welcome from a southern neighbor... Waiting for the warmth weather.
__________________
Walter & Donna
2011 CC LB RAM 3500 CTD 6.7L DRW
2013 Cedar Creek 38FL
2017 Days Planned: 135

38FLCamper is offline   Reply With Quote
Old 04-08-2014, 09:48 PM   #5
Senior Member
 
Join Date: Feb 2012
Location: Wisconsin
Posts: 9,505
Welcome from Wisconsin and congrats on your new camper.
__________________
Wiscampsin is offline   Reply With Quote
Old 03-21-2015, 01:32 PM   #6
Junior Member
 
Join Date: Mar 2014
Posts: 2
Well we used the camper all last summer as a seasonal. Only a few issues. The awning rolls up a little crooked, no big deal. The big issue was the toilet to black water tank connection. Had an awful smell coming from under sink. Pulled the toilet off and found that the flange was ever seated properly in the tank. Tank was mounted and the top was on a slight angle. They just used a bunch of caulking to seal it cause the threads never lined up. Went to a local hardware store and pick up adapters heat top of tank up and bent the last c so it sat level and then put in the adapters. Have not had an issue since. Deconed the und er belly and smell is gone.
__________________

__________________
amatsoniii is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:14 PM.