Thread Tools Display Modes
Old 06-29-2014, 09:08 PM   #1
Junior Member
Join Date: Jun 2014
Posts: 1
New owner of a new to me pop up

SO i just bought a new to me pop up camper over the weekend. I knew it needed a Little TLC when i bought if but that was fine. I had the previous owner show me how to set it up, raise and lower roof, support jacks etc. My issue now is i got it home and went to set it up to clean it out and start a few repairs and low and behold it wont raise in the rear. The front goes up just fine but nothing at the rear. So i raised it a little at a time, lifting the back with help whilei raised the front. When fully lifted i support the roof with wood braces and proceded to explore the lifting system.

I found that i have a set of chains attached to sprockets in the front, and pipe that runs the lenght of the camper under the cabinets, and at the rear another chain to a sprocket, with another sprocket just off set from the first. When i crank the handle the front sprocket turns, the bigger main sprocket at the rear turns, but the smaller off set sprocket at the rear does not turn, and that sprocket seems to make the springs do there thing and lift the roof.

I cant tell if there is a shear pin in that that may have sheared, or if there is an issue with a spring as im not at all familiar with this system yet and am having a hard time finding info on this system that either i can understnad or clean pictures that i can see. The other issue is that once its lifted, it will not lock in place anymore, ive had to brace the crank to stay in place. and lastly, how do i find out what year my cmaper is? In Wisconsin where im at, the camper is not required to be registed no there is no title etc and the person i bought it from was not the original owner and did not know.

So, in conclusion here are my issues.
Unit will not crank up in the rear, smaller rear sprocket does not spin.
Will not lock in place, front of unit, inside there seems to be a sprocket that has a locking portion on it, but when weight is on it that sprocket spins free.
I cannot find a VIN number anywhere on the frame, hitch area or a sticker inside any cabinets to determine the year of my camper. All i know is what it says on outside,
Rockwood 1006.

Any help at all, or follow up info from me for you to help determine any issue and repair would be greatly appreciated. Thank you.
bigjjred is offline   Reply With Quote

pop up

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:08 AM.