Reply
 
Thread Tools Display Modes
Old 01-05-2014, 04:35 PM   #1
Junior Member
 
Join Date: Jan 2014
Posts: 3
New to all this

Hello everyone, I'm new to the rv world and will pester you all with questions about how to repair my junker
__________________

__________________
mcleland is offline   Reply With Quote
Old 01-05-2014, 04:38 PM   #2
Senior Member
 
crunchman12001's Avatar
 
Join Date: Feb 2013
Location: Chagrin Falls, Ohio
Posts: 3,074
mcleland,
Welcome to the forum.
What brand and make trailer do you call your junker? What year ect...
Any pictures would help us help you.
crunchman
__________________

__________________
2017 Salem Villa Estate 395RET-
2011 Coachmen Freedom Express 295RLDS- Sold
2015 F-250 FX4
crunchman12001 is offline   Reply With Quote
Old 01-05-2014, 04:54 PM   #3
Junior Member
 
Join Date: Jan 2014
Posts: 3
I have a 92 allegro bay motor home and lost 12 volt power. I'm showing almost 14 volts but if I turn on lights or furnace power goes dead? I'm at a loss on what to do. I'm plugged into shore power and have a charger hooked to battery but same thing.
__________________
mcleland is offline   Reply With Quote
Old 01-05-2014, 05:09 PM   #4
Senior Member
 
ourflat's Avatar
 
Join Date: Dec 2013
Location: Pikeville NC
Posts: 321
Welcome! I believe most of us in the RV community have that special motorhome that got us started. Mine was a 2000 Fleetwood Tioga Arrow Class C. I started by searching the internet and manufacture websites for any thing I could to repair my MH. You'll be up and running in no time. Keep an eye on any water leaks on your coach since water damage is the hardest thing to repair. I had to rebuild the whole overhead cab because of a bad seal in the overhead cab window.

The other two items to keep a close watch on are relays and ground wires. Both can cause the problem you are experiencing.


Frank
__________________
ourflat is offline   Reply With Quote
Old 01-05-2014, 05:12 PM   #5
Senior Member
 
litgrep's Avatar
 
Join Date: Jun 2013
Location: mid Michigam
Posts: 106
Are you on shore power, generator, running motor, or just on 12 volt? Sounds like bad ground or cables.
__________________
litgrep is offline   Reply With Quote
Old 01-05-2014, 05:25 PM   #6
Junior Member
 
Join Date: Jan 2014
Posts: 3
I'm on shore power. I have a charger hooked to battery as a buffer but when I turn on furnace all power drops to 3 volts? Is there a way to bypass so I can run furnace since it's -5 up here rt now?
__________________
mcleland is offline   Reply With Quote
Old 01-05-2014, 05:40 PM   #7
Moderators' Assistant
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 13,260
welcome to FRF!

just so you know, Allegro Bay is not a Forest River brand.
so you should be able to get help with general RV things but not with things specific to your make/model of RV.

i would think that there's a Tiffin owner's website somewhere. they're pretty loyal owners of their Tiffin products.
__________________
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH and Prodigy BC
bikendan is offline   Reply With Quote
Old 01-05-2014, 05:41 PM   #8
Senior Member
 
litgrep's Avatar
 
Join Date: Jun 2013
Location: mid Michigam
Posts: 106
Sounds like a bad battery. Can you disconnect it an run on converter alone? Make sure terminals are clean. Also, verify your furnace blower moves freely. They're famous varmit homes and a stuck dc motor can do this too.
__________________
litgrep is offline   Reply With Quote
Old 01-05-2014, 05:44 PM   #9
Phat Phrog Stunt Crew
 
awwall's Avatar
 
Join Date: Jun 2012
Location: Biloxi, Ms
Posts: 704
Quote:
Originally Posted by mcleland View Post
I have a 92 allegro bay motor home and lost 12 volt power. I'm showing almost 14 volts but if I turn on lights or furnace power goes dead? I'm at a loss on what to do. I'm plugged into shore power and have a charger hooked to battery but same thing.
Welcome to the Forum!! When you say "goes dead". what exactly are you saying? Goes to 0 volts? If not, what does the DC volts drop too? Knowing this would help in troubleshooting.
__________________
Wayne & Susan Biloxi,Ms
2012 GeorgeTown 351DS...2015 Ford Focus/Brake Buddy
FROG Member
awwall is offline   Reply With Quote
Old 01-05-2014, 06:46 PM   #10
Senior Member
 
rracer5's Avatar
 
Join Date: Jan 2011
Location: Full Timing It
Posts: 1,902
Take the battery out and take it to an auto parts store like AutoZone. They will check its' condition for free. If it fails, they have RV/marine batteries in stock.

After that, if still nothing works, check all connections from the battery to the converter/charger. A loose connection will show 12v w/o load but if the connection isn't good enough under a load, the voltage will drop off cause "it can't flow thru a bad connection efficiently".
__________________

__________________
"PT Crew Members Since 9/2010"[/I][/B]
2011 RAM 2500 HD 6.7L CTD Crew
2014 Sanibel 3250
rracer5 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:17 AM.