Thread Tools Display Modes
Old 05-06-2013, 10:58 AM   #1
Junior Member
Join Date: May 2013
Location: Vail, AZ
Posts: 1
Newbie in AZ

Just finished the first weekend in our New Catalina 32TSBH here in southern Arizona, compared to the POP-up we used to have this is a mansion to camp in. Only small problem is the grey water indicator stayed on E the whole time when it was really full. Any ideas for this problem or do I need to return to the dealer for repair?

duprasm is offline   Reply With Quote
Old 05-06-2013, 02:04 PM   #2
Senior Member
Wiscampsin's Avatar
Join Date: Feb 2012
Location: Wisconsin
Posts: 8,131
Welcome to the forum and congrats on your new Catalina 32TSBH. Maybe the probes in the grey tank aren't registering so a trip back to the dealer would be a good idea. But be warned, the tank indicators aren't the most accurate things.
2013 Palomino Sabre 34REQS-6

Link to pics:
Wiscampsin is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:53 PM.