Reply
 
Thread Tools Display Modes
Old 03-03-2016, 09:18 AM   #1
Senior Member
 
banda's Avatar
 
Join Date: Mar 2015
Posts: 234
Has anyone used the Tech-Edge iSeries Tank Monitor?

Has anyone used the Tech-Edge iSeries Tank Monitor? https://tankedge.com/products.html I have used a SeeLevel monitor and liked it, but after only a couple of years it is becoming erratic in it's readings, so I am considering switching to this brand. Anyone have experience with the iSeries?
__________________

__________________
banda is offline   Reply With Quote
Old 03-04-2016, 12:28 PM   #2
Senior Member
 
banda's Avatar
 
Join Date: Mar 2015
Posts: 234
No one?
__________________

__________________
banda is offline   Reply With Quote
Old 03-04-2016, 08:18 PM   #3
Senior Member
 
Join Date: Oct 2015
Posts: 238
I have had and used the iSeries in 2 different campers. I love the unit and plan to put it in my new camper this spring. One of the very good points I would like to make is tech support. I had a power surge of some kind and shorted the board, I sent the panel in and for $25 the repaired it and sent it back to me. A down side to the system is it does take some time to run all new wires from each tank to the panel. You can't really use the existing wiring because the existing wiring is 1 wire from each tank and the iSeries needs 2 wires from each tank back to the panel. The iSeries system was always 100% accurate. Also you can custom set alarms for what ever setting full or empty you want. i.e. Black tank you want to alarm at 80% full but grey tank you are not as worried about maybe so you set that one at 87% full and your fresh tank you set at 20% until empty.


Eastlake, Ohio
2013 F-350 Turbo Diesel
2016 Heritage Glen 368rlbh
__________________
Dinostop is offline   Reply With Quote
Old 03-05-2016, 10:50 AM   #4
Senior Member
 
banda's Avatar
 
Join Date: Mar 2015
Posts: 234
Thanks, sounds like a good system, even with the wiring requirement.
__________________
banda is offline   Reply With Quote
Old 04-04-2016, 08:33 AM   #5
Senior Member
 
banda's Avatar
 
Join Date: Mar 2015
Posts: 234
Well I thoroughly checked all my wiring and it was fine. Turns out the monitor panel itself had become faulty. Bought a new one and all is good now.
__________________
banda is offline   Reply With Quote
Reply

Tags
tank

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:56 PM.