Thread Tools Display Modes
Old 01-07-2016, 01:55 AM   #51
Senior Member
Witch Doctor's Avatar
Join Date: Feb 2012
Location: Clarksville Va.
Posts: 6,846
I never heard of such a problem with a melted stat. It should have been just running off the 12 volt battery in the stat. As far as your lights dimming what might have caused that is your 12 volt furnace motor pulling to many amps. I suggest that you get the furnace blower looked at plus the whole unit. Always a good idea to put a fuse in-line. Thankfully you were there to catch it and your okay. Did you put the old stat back on and try it again?

Rockwood #8289 WS 2012
F250 6.0 / Husky 16k
With 4 point leveling system
Witch Doctor is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:07 PM.