Thread Tools Display Modes
Old 05-07-2014, 09:02 PM   #1
Junior Member
Join Date: May 2014
Posts: 13
2014 Spartan

Back again.... tried the fuel station for the first time and it don't work. Nothing. Don't know where to start. New to this 5er life and seems like a lot of bugs to work out. Any ideas?

Sent from my SM-G900V using Forest River Forums mobile app

polarbear is offline   Reply With Quote
Old 05-26-2014, 02:20 PM   #2
thrilskr123's Avatar
Join Date: Mar 2014
Location: Phoenix
Posts: 12
You might have a switch that turns the pump on. I have a master switch by my fuel gauge and a transfer pump switch outside my fuel box to the left. You may get some help from the dealer you bought it from.
'Life's too short to drink cheap beer'

06' Sierra Sport F37SP
12' Chevy 4X4 LB CC 1T Dually
B&W Companion 20K
thrilskr123 is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:38 PM.