Thread Tools Display Modes
Old 08-10-2012, 06:45 PM   #1
Junior Member
Join Date: Aug 2012
Posts: 1
Cub Aerolite 2002

Have installed new battery, is fully charged but not working. Would welcome suggestions.

Rolling Along is offline   Reply With Quote
Old 08-11-2012, 07:50 AM   #2
Moderator Emeritus
Triguy's Avatar
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,951
First of all

A few things to look for:

Did you charge the battery? I realize you say its fully charged, but wondering if you fully charged it with your own charger. New batteries might not be fully charged unless someone did this. Usually the place you got it from does this for you, but some just take if off the shelf where its been sitting for awhile and say its fully charged.

Confirm that you have it wired correctly with the negative cable grounded to the frame and positive leading to your converter. Miswiring is an issue we have seen before.

Confirm that your fuses and breakers are good. There should be an inline fuse on the positive cable running to the converter close to the battery. This could need replacing or it might be a resettable fuse. This is a box that has a tiny button you can use to reset it.

That's a start and let us know how it goes.

DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 08-11-2012, 07:58 AM   #3
Moderator Emeritus
Join Date: Nov 2008
Location: Winston-Salem, NC
Posts: 2,381
Hello, and to the forums. Hope you enjoy the stay, and learn a lot, and can teach others what you already know. As for not working, what is not working? Does anything not working, work when plugged in?
2012 Ford F250 ext. Cab 4x4
2002 Jeep Wrangler Sahara
2008 Yamaha V-Star 650 Classic

2008 Work and Play 18LT
LadyWindrider is offline   Reply With Quote
Old 08-11-2012, 08:45 PM   #4
Moderators' Assistant
bikendan's Avatar
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 10,208
the resettable breaker/fuse is the most common cause.
has a black button on the side to reset.
happens usually when a new owner hooks up the battery wires backwards.
Dan-Retired Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
'07 Roo 23SS pushing an '07 Chevy Avalanche
Equalizer WDH and Prodigy BC
bikendan is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:17 AM.