Thread Tools Display Modes
Old 03-13-2015, 09:18 AM   #1
Junior Member
Longhorn 105's Avatar
Join Date: Feb 2015
Location: Barnesville, GA
Posts: 13
Back up camera

a back up camera system came with my new Columbus 320RS. this week was the first long trip we have taken in it and this camera is not working so good. It is approximately 47 feet from the camera to the screen and it does not hold a signal. does any one know how to increase the signal.

Mike & Patty
2014 Ram 3500 Longhorn 6.7L 4x4
2015 Columbus 320RS
Days Glamping 2015 - 13
Longhorn 105 is offline   Reply With Quote
Old 03-14-2015, 10:32 AM   #2
Senior Member
Join Date: Jan 2011
Posts: 276
My buddy Ike and I have had the same problem as you. his is a furrion and mine a Voyager. The cure for us was to add an 80" Antenna extension along with a 35' extension cable. By doing this it put the antenna on the front cap of our 40' 5th wheels. We got the parts from

cbvp is offline   Reply With Quote

back up camera

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:44 PM.