Reply
 
Thread Tools Display Modes
Old 08-29-2016, 10:52 AM   #11
Senior Member
 
Wolverine 1945's Avatar
 
Join Date: Jul 2014
Location: SouthWest Michigan
Posts: 2,407
Maybe a stupid question,,, but have you check the water faucet before it enters your unit ??? And maybe the hose you are using ???
GOOD LUCK !!!
__________________

__________________
Wolverine 1945 is offline   Reply With Quote
Old 08-29-2016, 04:07 PM   #12
Fulltime family RVer
 
ependydad's Avatar
 
Join Date: Nov 2011
Posts: 14,235
Quote:
Originally Posted by jtstromsburg View Post
Have you flushed the washing machine lines?
This was my issue. I bleached the water system but neglected to sanitize the washing machine lines in the front closet because they're a hassle to get to. My problem came back within 2 weeks WITH A VENGEANCE.

We re-sanitized the system and made sure to get those. The moment my wife opened the tap up there, she almost threw up.

Eww, stinky water! Sanitizing the fresh water system. | Learn To RV
__________________

__________________
2012 Ram 3500 DRW/crew cab/long bed/4x4/4.10 gears pulling an early 2013 Sabre 36QBOK
Checkout my site for RVing tips, tricks, and info | My family and I have fulltimed since June 2015
ependydad is offline   Reply With Quote
Old 08-29-2016, 05:15 PM   #13
Junior Member
 
Join Date: Aug 2016
Posts: 9
I would think if it was the camp ground water, all of the campers would be having this issue or at least in my area. There are about 12 campers on our line and only the Sierra's are having the issues. Hot and Cold water, so it makes be believe there is a flaw somewhere in our water lines. Something is not getting flushed properly. If you run about 15 - 20 gallons of water though it, it will be much better, but when you leave it for a few hours it is back. I've tried different filters, no filter, filter on the hose. Nothing seems to work. It would be nice if FOREST RIVER would step up and let us know how to fix this issue.
__________________
Denise13065 is offline   Reply With Quote
Old 08-29-2016, 05:20 PM   #14
Junior Member
 
Join Date: Aug 2016
Posts: 9
I initially bleached the hose too and since that didn't help, I bought a new hose. Same thing. I have not checked the Faucet, but I will do that. Again, only the Sierra's are having this issue. There are about 12 campers in our line and 4 of us have Sierra's. ONLY the Sierra's are having the issue.
__________________
Denise13065 is offline   Reply With Quote
Old 08-29-2016, 05:22 PM   #15
Junior Member
 
Join Date: Aug 2016
Posts: 9
I'm the only camper with a Wash machine and my water doesn't smell as bad as a couple of the other Sierra's. I'm trying to fix mine so it doesn't smell as bad as theirs.
__________________
Denise13065 is offline   Reply With Quote
Old 08-30-2016, 07:46 AM   #16
Senior Member
 
Wolverine 1945's Avatar
 
Join Date: Jul 2014
Location: SouthWest Michigan
Posts: 2,407
I would first make sure it is not a CG problem !!!
Stranger things have happened !!!
Again,,, GOOD LUCK !!!
__________________
Wolverine 1945 is offline   Reply With Quote
Old 09-07-2016, 11:49 PM   #17
Junior Member
 
collinpr's Avatar
 
Join Date: Aug 2014
Posts: 16
Okay, this past season in Yuma, had the sulfur smell bad. Did the bleach thing, helped very little.

Then occurred to me those water lines going to where a washer would be...
yep, opened those up and just about enough to make you puke. Loaded more bleach and ran thru the entire system. Presto fixed.
__________________
collinpr is offline   Reply With Quote
Old 09-08-2016, 12:15 AM   #18
Senior Member
 
Capsfloyd's Avatar
 
Join Date: Jan 2012
Location: Lancaster TX
Posts: 245
If you have a on board canister water filter, change that. Put on on the outside before water comes in
__________________
2009 Rambox crew cab
2012 831 Flagstaff RKSS
2010 jeep Liberty
2010 Harley Davidson Ultra Classic
Capsfloyd is offline   Reply With Quote
Old 09-08-2016, 07:57 AM   #19
Junior Member
 
collinpr's Avatar
 
Join Date: Aug 2014
Posts: 16
Quote:
Originally Posted by Capsfloyd View Post
If you have a on board canister water filter, change that. Put on on the outside before water comes in
Yeah, got rid of the in line filter that came with the unit. Use external filters, no difference until I sanitized the whole system including the washer lines to the front closet.

I may install valves to close those lines off this coming winter season down South, no intention of having a washer in there.

My unit is a 365RL. Same issue at different parks.
__________________
collinpr is offline   Reply With Quote
Old 11-27-2016, 07:41 PM   #20
Junior Member
 
Join Date: May 2014
Location: Register, Georgia
Posts: 11
Hi

I'll tell you what I it is its not the water its the air vent under the sink for the drain, its bad and needs to be replaced. its a black vent on the top of the pipe coming from the drain pipe its not closing the air value to close of the smell. It does not have a pee trap. To drain the sink the vent will let air in the drain sink and close when no water is draining. Its bad.
__________________

__________________
Jerrymac is offline   Reply With Quote
Reply

Tags
camper, water

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:15 AM.