Reply
 
Thread Tools Display Modes
Old 08-05-2014, 12:24 PM   #1
Junior Member
 
Join Date: Jul 2013
Posts: 11
City Water

Hi all,
I had the opportunity to use the city water for the first time last week and for some reason the water was running constantly in the faucet regardless the position on or off. Have I missed something? Didn't I supposed to just plug in the hose and use the water?
Thank you
Paul
2005 Rockwood freedom 2270
__________________

__________________
Paul Maple is offline   Reply With Quote
Old 08-05-2014, 12:27 PM   #2
Senior Member
 
Dennis and Julie's Avatar
 
Join Date: Mar 2012
Location: Williston ND
Posts: 305
Do you have a pressure regulator for your hook up? If we don't use one our toilet bowl fills. RV plumbing cannot handle the high pressure campground hook ups sometimes put out.
__________________

__________________
Dennis and Julie
2012 Flagstaff 30WFKSS
2013 Chevy Silverado 2500HD
2012 Chevy Silverado 2500HD
Dennis and Julie is online now   Reply With Quote
Old 08-05-2014, 01:15 PM   #3
Senior Member
 
Campin Cajun's Avatar
 
Join Date: Mar 2013
Location: Cut Off, La.
Posts: 1,830
What faucet was running on or off?


2013 Berkshire 390 BH
__________________
2013 Berkshire 390BH
Campin Cajun is offline   Reply With Quote
Old 08-05-2014, 01:16 PM   #4
Junior Member
 
Join Date: Jul 2013
Posts: 11
no, we don't have one, but it leaked even when we opened the water just a bit. I will do some research on the pressure regulator.
thank you
__________________
Paul Maple is offline   Reply With Quote
Old 08-05-2014, 01:17 PM   #5
Junior Member
 
Join Date: Jul 2013
Posts: 11
the one in my sink, the city water side.
__________________
Paul Maple is offline   Reply With Quote
Old 08-05-2014, 01:34 PM   #6
Senior Member
 
Join Date: May 2014
Posts: 782
What sink kit or bath?
__________________
kinma13 is offline   Reply With Quote
Old 08-05-2014, 01:40 PM   #7
Junior Member
 
Join Date: Jul 2013
Posts: 11
kit, we don't have bath.
__________________
Paul Maple is offline   Reply With Quote
Old 08-05-2014, 10:30 PM   #8
Senior Member
 
Join Date: May 2014
Posts: 782
Id really point to the press reg but you might have a o ring bad in the faucet.
__________________
kinma13 is offline   Reply With Quote
Old 08-06-2014, 08:45 AM   #9
Junior Member
 
Join Date: Jul 2013
Posts: 11
I'm going to check the faucet this weekend and already ordered a pressure regulator. Plenty of time until the next trip.
Thank you all
__________________

__________________
Paul Maple is offline   Reply With Quote
Reply

Tags
water

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:18 PM.