Reply
 
Thread Tools Display Modes
Old 04-01-2013, 04:51 PM   #1
Junior Member
 
Join Date: Mar 2013
Posts: 9
Question motorized lift on 2008 rockwood not working

Our power lift on our Rockwood popup is not working. what could the problem be? Thank goodness, we called the rockwood dealer that told us the location of the hand crank system, so were able to get it up for the camping weekend and back down. Takes 1/2 hour by hand. Replaced a fuse, but that made no difference.
__________________

__________________
jeanbon is offline   Reply With Quote
Old 04-01-2013, 09:46 PM   #2
Campin With Grammy & Papa
 
Scott n Jo's Avatar
 
Join Date: Sep 2012
Location: Nevada
Posts: 35
Mine, the first time I tried it this year would not work. Battery was dead. Hooked jumper cables to the PUP battery and the lift worked. Then placed my battery charger on after, got a good charge. Worked every since. Maybe? Hope you figure it out. Scott
__________________

__________________
DH, DW, DS
2008 Kia Sedona
2013 Rockwood HW277
Scott n Jo is offline   Reply With Quote
Old 04-01-2013, 10:30 PM   #3
Junior Member
 
Join Date: Mar 2013
Posts: 9
How nice that would be if it was just the battery!! It is a new battery, but possibly we didn't have it charged up enough. My son lives in Summerliln Nevada, and he bought our 2000 that was like and we "upgraded to a 2008"

Thank you so much for your tip.

Jean and Don
__________________
jeanbon is offline   Reply With Quote
Old 04-02-2013, 09:21 AM   #4
Senior Member
 
HONDAMAN174's Avatar
 
Join Date: Jun 2011
Location: Big brown desert
Posts: 2,319
Make sure that the "circuit breaker" (2inch square box) has good contact to the positive terminal of the battery.
__________________
2014 Stealth Evo 2850- "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7- "Clifford"
2013 Honda Accord Coupe V6 w/Track Pack- "Julia"

Just glad to get away
HONDAMAN174 is offline   Reply With Quote
Old 04-09-2013, 05:57 PM   #5
Take The Road Less Travld
 
MuddauberE's Avatar
 
Join Date: Apr 2013
Location: Cincinnati
Posts: 499
Quote:
Originally Posted by HONDAMAN174 View Post
Make sure that the "circuit breaker" (2inch square box) has good contact to the positive terminal of the battery.
Two possibilities that I have run into, there is a fuse on my 2007 rockwood popup that is under the motor where the wiring is for the lift hidden inside electrical tape. You'll have to get under the tongue and remove the plastic cover to get to it. This fuse was bad. It was a 50 amp fuse that had to replace with a 60 amp as recommended by the lift manufacture.

Two, the lift only runs off the battery and does not have the ability to run off the power inverter. So yes, check the battery. I think there should be an allowance to run it off of ac. Guess you can't have both. Maybe the power inverter can't handle the amps.
__________________
"Take The Road Less Traveled"
2013 Rockwood Roo 233s
2017 Ford F-150 EB
I've been an RVer since 2007, Lifetime Camper
Gotta love the Outdoors, Disconnect and Enjoy Nature!
MuddauberE is offline   Reply With Quote
Old 04-10-2013, 12:07 PM   #6
Junior Member
 
Join Date: Mar 2013
Posts: 9
Good news. We only had one ground wire hooked up, and there are two. One white wire and one black for negative. Works perfect now. jean
__________________

__________________
jeanbon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:37 PM.