Reply
 
Thread Tools Display Modes
Old 04-28-2013, 08:00 AM   #1
Member
 
wayne in florida's Avatar
 
Join Date: Apr 2013
Posts: 69
Lightbulb No Power to 12v inside lights. Roof only

Can't seem to get the lights on inside. Both buttons pushed under stove to activate.???????
__________________

__________________
wayne in florida is offline   Reply With Quote
Old 04-28-2013, 08:02 AM   #2
Member
 
wayne in florida's Avatar
 
Join Date: Apr 2013
Posts: 69
Sorry I have a MAC BR28TSC
__________________

__________________
wayne in florida is offline   Reply With Quote
Old 04-28-2013, 08:03 AM   #3
Professional Texan
 
TexasBob's Avatar
 
Join Date: Mar 2013
Location: Texas
Posts: 324
Quote:
Originally Posted by wayne in florida View Post
Can't seem to get the lights on inside. Both buttons pushed under stove to activate.???????
Please post the make and model of your RV. There will be owners of the same RV that can help you best. ... and check your fuses.
__________________
Texas Bob
2015 Chevrolet Silverado HD2500 Z71
2013 Prime Time Tracer Executive 2640 RLS

TexasBob is offline   Reply With Quote
Old 04-28-2013, 08:59 AM   #4
Senior Member
 
Join Date: Nov 2012
Location: X
Posts: 2,781
When I had a Fleetwood popup, there was a switch that was activated when the aft bed was fully extended. That switch (or the metal sheet that was supposed to move it) was quite temperamental. I was told that this was a safety feature to keep power off of the RV when it wasn't opened up. Perhaps that's what's wrong here.

(And two switches you've turned on? Isn't one of those for the fresh water pump?)
__________________
BarryD0706 is offline   Reply With Quote
Old 04-28-2013, 11:20 AM   #5
Junior Member
 
Join Date: Mar 2013
Location: Georgia
Posts: 3
First, check the fuses. Should be a LED showing beside the fuse if it is blown. Should be 2 wires going up beside the strut near the power panel. Make sure that the connector is not disconnected or that the wires have been pinched/cut.
__________________
Jarhead71 is offline   Reply With Quote
Old 04-28-2013, 01:55 PM   #6
Member
 
wayne in florida's Avatar
 
Join Date: Apr 2013
Posts: 69

Found it.....Bad wire nut.!!!!
__________________

__________________
wayne in florida is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:02 AM.