Reply
 
Thread Tools Display Modes
Old 11-19-2011, 06:42 AM   #1
Junior Member
 
Join Date: Nov 2010
Location: Valdosta, GA
Posts: 5
popup power lift stopped working

I sure hope someone can help me with this...I have a 07 Forest River Flaggstaff pop up camper with a power lift. Needless to say, the it stopped working and now I can't get the top to go up or back down. I swapped out the battery but nothing happened. I ended up leaving it at the campground and went back home (only an hour away). I'm going back today to change out the fuse but if that doesnt work, I really don't know what else to do, anyone have any ideas??? Thanks in advance.

PS...If I cut the cable (last resort), will the top go down automatically?
__________________

__________________
roxsteven is offline   Reply With Quote
Old 11-19-2011, 06:49 AM   #2
Senior Member
 
grhodes50's Avatar
 
Join Date: Dec 2007
Location: Eastern Oklahoma, USA
Posts: 2,613
Check your manuals. There should be instructuons on how to raise/lower the top manually. There should be a tool similar to the one for your stabilzer jacks to do this.

I hope it's the fuse. That's an easier fix! Good luck!
__________________

__________________

Gary & Trish
"PT Crew Member Since 11/2010"
2017 Prime Time Crusader 315RST TE 6.0 : 2007 Flagstaff 206ST MAC Series
2012 F-250 Lariat : FX4 : CC : SB : 6.7L Diesel : 3/55 Gears

2017 Nights Camped - 4
grhodes50 is offline   Reply With Quote
Old 11-19-2011, 06:55 AM   #3
Junior Member
 
Join Date: Nov 2010
Location: Valdosta, GA
Posts: 5
Thanks for your quick response, unfortunately I bought this trailer through an auction and it didnt come with any manuals. I have taken the cover off the power lift before to look for the manual override but I think the previous owners broke it off because it looks like it was sheared off. I really hope it's the fuse too. Thanks again!
__________________
roxsteven is offline   Reply With Quote
Old 11-19-2011, 07:05 AM   #4
Senior Member
 
grhodes50's Avatar
 
Join Date: Dec 2007
Location: Eastern Oklahoma, USA
Posts: 2,613
Here's the instructions from my manual.
Pop-Up Motor.pdf

Hope this helps you.

__________________

Gary & Trish
"PT Crew Member Since 11/2010"
2017 Prime Time Crusader 315RST TE 6.0 : 2007 Flagstaff 206ST MAC Series
2012 F-250 Lariat : FX4 : CC : SB : 6.7L Diesel : 3/55 Gears

2017 Nights Camped - 4
grhodes50 is offline   Reply With Quote
Old 11-19-2011, 07:12 AM   #5
Junior Member
 
Join Date: Nov 2010
Location: Valdosta, GA
Posts: 5
It does, I downloaded it several months ago and that 7/16' bolt for the manual override is missing. I really think its a power issue (fuse) because the last time the motor loosened up the motor made a loud clacking noise but this time there was nothing.
__________________
roxsteven is offline   Reply With Quote
Old 11-19-2011, 07:23 AM   #6
Senior Member
 
grhodes50's Avatar
 
Join Date: Dec 2007
Location: Eastern Oklahoma, USA
Posts: 2,613
Check all of your wiring. I had that same problem once with the clicking noise and the cause was, gears had worn through the wiring insulation and the bare wire was touching the metal.
__________________

Gary & Trish
"PT Crew Member Since 11/2010"
2017 Prime Time Crusader 315RST TE 6.0 : 2007 Flagstaff 206ST MAC Series
2012 F-250 Lariat : FX4 : CC : SB : 6.7L Diesel : 3/55 Gears

2017 Nights Camped - 4
grhodes50 is offline   Reply With Quote
Old 11-19-2011, 07:26 AM   #7
Junior Member
 
Join Date: Nov 2010
Location: Valdosta, GA
Posts: 5
will do, thanks again!
__________________
roxsteven is offline   Reply With Quote
Old 11-21-2011, 03:28 PM   #8
daydreaming about camping
 
jeeplj8's Avatar
 
Join Date: Jun 2011
Location: KC area
Posts: 1,400
Quote:
Originally Posted by roxsteven View Post
It does, I downloaded it several months ago and that 7/16' bolt for the manual override is missing. I really think its a power issue (fuse) because the last time the motor loosened up the motor made a loud clacking noise but this time there was nothing.
Are you sure? The hole should be full of greese. with all that greese packed I could not even see the bolt head down there.
__________________

2013 Coachmen Freedom Express 320BHDS pulled by a 2005 F250 King Ranch CC

A rainy day camping is better than a sunny day at work.
jeeplj8 is offline   Reply With Quote
Old 11-21-2011, 10:50 PM   #9
Junior Member
 
Join Date: Nov 2010
Location: Valdosta, GA
Posts: 5
I'm sure, I've taken it apart this summer because the motor got loose and made a loud clacking noise. I had removed all of the grease just to make sure I wasn't missing something but there definitely isn't a 7/16 bolt there.
__________________
roxsteven is offline   Reply With Quote
Old 11-23-2011, 09:38 AM   #10
daydreaming about camping
 
jeeplj8's Avatar
 
Join Date: Jun 2011
Location: KC area
Posts: 1,400
wow - that bolt is actualy the top of the worm drive itself. If they sheared it off, I am shocked the system still works at all.

Hopefully your issue was electrical, and you got your camper down. However I would NOT use it again until replaced.
__________________

__________________

2013 Coachmen Freedom Express 320BHDS pulled by a 2005 F250 King Ranch CC

A rainy day camping is better than a sunny day at work.
jeeplj8 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:02 PM.