Reply
 
Thread Tools Display Modes
Old 07-19-2014, 08:45 PM   #1
Junior Member
 
Join Date: Mar 2012
Location: Florida
Posts: 11
Water Pressure

I have a 2012 High Wall. The water pressure has always been good, until our most recent trip. We have a lot less at the sink, shower and toilet flush. Could this be the water filter?
__________________

__________________
Judgedcm is offline   Reply With Quote
Old 07-19-2014, 08:47 PM   #2
Senior Member
 
HONDAMAN174's Avatar
 
Join Date: Jun 2011
Location: Big brown desert
Posts: 2,319
Are you on city water or water pump?


2014 Stealth Evo 2850 "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7 "Clifford"
__________________

__________________
2014 Stealth Evo 2850- "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7- "Clifford"
2013 Honda Accord Coupe V6 w/Track Pack- "Julia"

Just glad to get away
HONDAMAN174 is online now   Reply With Quote
Old 07-19-2014, 08:49 PM   #3
Junior Member
 
Join Date: Mar 2012
Location: Florida
Posts: 11
City water at campground
__________________
Judgedcm is offline   Reply With Quote
Old 07-19-2014, 08:59 PM   #4
Senior Member
 
HONDAMAN174's Avatar
 
Join Date: Jun 2011
Location: Big brown desert
Posts: 2,319
Are you using a pressure regulator?

Sometimes hose bibs have them already when you get there and are clogged.

Some people do remove their filter inside their unit and run an external filter for higher water pressure. Problem is on most high walls water filter is directly above your power converter making its servicing a messy ordeal.


2014 Stealth Evo 2850 "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7 "Clifford"
__________________
2014 Stealth Evo 2850- "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7- "Clifford"
2013 Honda Accord Coupe V6 w/Track Pack- "Julia"

Just glad to get away
HONDAMAN174 is online now   Reply With Quote
Old 07-19-2014, 09:01 PM   #5
Junior Member
 
Join Date: Mar 2012
Location: Florida
Posts: 11
I have a pressure regulator, and used it until I had the pressure issue. I thought it might be clogged, so I took it off. Same issue. I have not looked at the filter yet, but wondered if anyone had a problem with clogging at that point.
__________________
Judgedcm is offline   Reply With Quote
Old 07-19-2014, 09:10 PM   #6
Member
 
Join Date: Sep 2011
Posts: 42
even if you are using city water hookup some campgrounds have very hard water and it will clog up the filter very fast may need to look at that I took the preasure regulator off of my old camper and broke all the water lines one by on after that so not a good idea to eliminate one
__________________
jkklops is offline   Reply With Quote
Old 07-19-2014, 11:04 PM   #7
Junior Member
 
Join Date: Mar 2012
Location: Florida
Posts: 11
Just saw several posts about the WaterPur Filters being garbage, including this one from someone that fixed the problem - "Today I completely removed the filter fixture after disconnecting the inlet and outlet hoses. I joined the two hoses with a 1/2" x 6" SCH80 PVC nipple purchased from Ace Hardware, $1.49. No installation issues. I'll connect a filter outside between the water source and the camper."

I think I will go that route.
__________________
Judgedcm is offline   Reply With Quote
Old 07-19-2014, 11:39 PM   #8
Senior Member
 
HONDAMAN174's Avatar
 
Join Date: Jun 2011
Location: Big brown desert
Posts: 2,319
Good deal. Hope it solves your issue.

Never understood why they put the water filter (which you have to replace) right over the power station. Seems like a larger problem waiting to happen.


2014 Stealth Evo 2850 "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7 "Clifford"
__________________
2014 Stealth Evo 2850- "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7- "Clifford"
2013 Honda Accord Coupe V6 w/Track Pack- "Julia"

Just glad to get away
HONDAMAN174 is online now   Reply With Quote
Old 07-20-2014, 02:32 AM   #9
Senior Member
 
SKnight's Avatar
 
Join Date: Feb 2014
Posts: 1,428
Could have been low pressure at the spigot. I bought a $12 screw on pressure gauge from Home Depot so I can check the incoming pressure as I connect. Under 60psi, I don't bother with the regulator to maximize flow.

Next time this happens turn off the spigot outside, turn on your on board pump and see if the situation improves. If it does, it's the incoming pressure. If not, possibly your filter, or maybe there's something else going on.
__________________

__________________
Now-2014 Sierra 346RETS 5er BUB
Then-2002 Keystone Springdale 286RLDS TT

Nights camped in 2014-28, 2015-127, 2016-10
SKnight is offline   Reply With Quote
Reply

Tags
pressure, water

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:28 PM.