Reply
 
Thread Tools Display Modes
Old 06-15-2014, 09:56 PM   #1
Junior Member
 
Join Date: Jun 2011
Location: NC
Posts: 23
2013 Sabre not in use but has popping noise underneath

We just returned from a week's trip and all went well except when we came home and turned everything off there's a clicking noise coming from underneath. Nothing is on in the camper. It's a regular clicking sound and would like to find the cause before something breaks. Have never heard it before. You help would be much appreciated!
__________________

__________________
thinkinghat is offline   Reply With Quote
Old 06-15-2014, 10:08 PM   #2
Senior Member
 
QCCowboy's Avatar
 
Join Date: May 2012
Location: Illinois
Posts: 880
Refrigerator on auto and power still on with electric disconnected? Click could be fridge trying to light on LP. If gas is shut it will just keep going. Water heater could be the same way if gas is off. You say underneath and these would be on the sides.
__________________

__________________
Jack of all trades - Master of none
2012 F350 CC DRW - 6.7L PSD
2014 Sabre 36QBOK
QCCowboy is offline   Reply With Quote
Old 06-15-2014, 10:49 PM   #3
Fulltime family RVer
 
ependydad's Avatar
 
Join Date: Nov 2011
Posts: 14,768
Did the emergency breakaway cable get pulled? Could the sound be your brakes clicking?
__________________
2012 Ram 3500 DRW/crew cab/long bed/4x4/4.10 gears pulling an early 2013 Sabre 36QBOK
Checkout my site for RVing tips, tricks, and info | My family and I have fulltimed since June 2015
ependydad is online now   Reply With Quote
Old 06-15-2014, 10:55 PM   #4
Junior Member
 
Join Date: Jun 2011
Location: NC
Posts: 23
I just went out and checked again but everything is off. Even the gas but it does sound like something is trying to start. The sound is coming from the front of the camper instead of the back where the appliances are located. It almost sounds like the wheels?!
__________________
thinkinghat is offline   Reply With Quote
Old 06-15-2014, 10:56 PM   #5
Junior Member
 
Join Date: Jun 2011
Location: NC
Posts: 23
I'll check the breakaway switch tomorrow since the sound seems to be coming from the front near the brakes. Crazy, to say the least! Thanks!!
__________________
thinkinghat is offline   Reply With Quote
Old 06-15-2014, 11:00 PM   #6
Senior Member
 
Evereddie's Avatar
 
Join Date: Feb 2013
Location: Pfafftown NC
Posts: 2,065
Quote:
Originally Posted by thinkinghat View Post
I'll check the breakaway switch tomorrow since the sound seems to be coming from the front near the brakes. Crazy, to say the least! Thanks!!
Hello fellow NCer. I would disconnect the battery, now.
__________________
Evereddie is offline   Reply With Quote
Old 06-15-2014, 11:04 PM   #7
Fulltime family RVer
 
ependydad's Avatar
 
Join Date: Nov 2011
Posts: 14,768
Quote:
Originally Posted by Evereddie View Post
Hello fellow NCer. I would disconnect the battery, now.

Agreed. Sounds like something pulled the breakaway. That'll likely run your battery VERY dead.
__________________

__________________
2012 Ram 3500 DRW/crew cab/long bed/4x4/4.10 gears pulling an early 2013 Sabre 36QBOK
Checkout my site for RVing tips, tricks, and info | My family and I have fulltimed since June 2015
ependydad is online now   Reply With Quote
Reply

Tags
2013, sabre

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:47 PM.