Reply
 
Thread Tools Display Modes
Old 03-18-2012, 06:03 PM   #1
Junior Member
 
rugmanrn's Avatar
 
Join Date: Mar 2012
Posts: 27
Black tank flush. F320

Hooked up to the black water flush on the new f320-rs for the first time. I don't hear any water running or draining. I don't see any valve to turn on for the black water flush. Hose is tight and full of pressure. Any advice. My old TT didn't have a black water flush
__________________

__________________
rugmanrn is offline   Reply With Quote
Old 03-19-2012, 05:59 AM   #2
Senior Member
 
ret2006's Avatar
 
Join Date: Jan 2011
Location: Nashville, TN
Posts: 364
Quote:
Originally Posted by rugmanrn View Post
Hooked up to the black water flush on the new f320-rs for the first time. I don't hear any water running or draining. I don't see any valve to turn on for the black water flush. Hose is tight and full of pressure. Any advice. My old TT didn't have a black water flush
Sometimes I have to turn the water on and then back off then on again sometimes to get the flow through the black tank flush. There is not a valve to turn just a hose connection. There is a check valve that may be stuck. Try turning the water on then off and on again. Works for me.
__________________

__________________
2014 Cedar Creek 34 RLSA-7
2015 Chevy Silverado 3500HD LTZ SRW

ret2006 is offline   Reply With Quote
Old 04-01-2012, 07:16 PM   #3
Junior Member
 
Join Date: Feb 2012
Posts: 25
Quote:
Originally Posted by rugmanrn View Post
Hooked up to the black water flush on the new f320-rs for the first time. I don't hear any water running or draining. I don't see any valve to turn on for the black water flush. Hose is tight and full of pressure. Any advice. My old TT didn't have a black water flush
Did you ever get the black tank flush to work? We are having the same
problem. Tried turning water on and off as recommended, still not working.
__________________
trudy66 is offline   Reply With Quote
Old 04-01-2012, 07:42 PM   #4
Junior Member
 
rugmanrn's Avatar
 
Join Date: Mar 2012
Posts: 27
Trudy
Yes I switched the two water lines in the storage area. I have the pictures if you need I can text or email you. It's under warranty but I bought a 30 dollar wrench to fix instead of coir hundred bucked in diesel to dealer
__________________
rugmanrn is offline   Reply With Quote
Old 04-01-2012, 08:15 PM   #5
Junior Member
 
Join Date: Feb 2012
Posts: 25
Yes could you email pics. We have tried everything aside from ripping the floor out. ( not really, just getting frustrated) Can't figure out what's wrong.
Would greatly appreciate it if you could.
__________________
trudy66 is offline   Reply With Quote
Old 04-01-2012, 10:12 PM   #6
Senior Member
 
Join Date: Feb 2012
Location: Wisconsin
Posts: 9,505
Like ret2006 said the check valve may be stuck. Or it may have been installed backwards.
__________________
Wiscampsin is offline   Reply With Quote
Old 04-01-2012, 10:17 PM   #7
Senior Member
 
Earth Station's Avatar
 
Join Date: Jan 2012
Posts: 627
We didn't have any problems. Dumped the first time at the dealer. DH says it is quieter than TT was. there is not a agitator in the 320RS it just sprays. He says it is very quiet.
__________________

Felicia & Jeff - Missouri
2013 Columbus - 320 RS 2012 F350 CC DRW - 6.7L PSD
2012 Camping 59 DAYS; 2013 50 DAYS; 2014 WAITING
Earth Station is offline   Reply With Quote
Old 04-02-2012, 07:43 AM   #8
Junior Member
 
rugmanrn's Avatar
 
Join Date: Mar 2012
Posts: 27
Mine works like a champ after switching the two water lines that go up and behind shower to check valve
__________________
rugmanrn is offline   Reply With Quote
Old 04-02-2012, 10:31 PM   #9
Member
 
Join Date: Feb 2012
Posts: 95
Quote:
Originally Posted by rugmanrn
Trudy
Yes I switched the two water lines in the storage area. I have the pictures if you need I can text or email you. It's under warranty but I bought a 30 dollar wrench to fix instead of coir hundred bucked in diesel to dealer
I am having the same problem with the black flush valves. Could you send me pictures at cuttinchief@gmail.com.thanks
__________________
Cuttinchief is offline   Reply With Quote
Old 04-03-2012, 09:00 AM   #10
Junior Member
 
rugmanrn's Avatar
 
Join Date: Mar 2012
Posts: 27
Trudy and cuttinchief. Just emailed pics and explain action. Let me know if you have any questions
__________________

__________________
rugmanrn is offline   Reply With Quote
Reply

Tags
black tank, black tank flush

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:52 AM.