Reply
 
Thread Tools Display Modes
Old 10-09-2016, 10:30 AM   #11
Junior Member
 
Join Date: Jul 2016
Posts: 24
Quote:
Originally Posted by Iggy View Post
Here is a short video.
https://youtu.be/u-AFa9hyrpI
Thanks Iggy. Looks like I have a little project for next weekend.
__________________

__________________
scbrown063 is offline   Reply With Quote
Old 10-09-2016, 01:28 PM   #12
Member
 
Join Date: Jan 2016
Posts: 67
My Cardinal was only 6 months old when I had to replace the black water valve. FR puts in cheap valves/cables (twisted wire). I replaced it with an of the shelf good quality valve (can't recall the name) with solid wire. I also cut a 3 sided hatch in the underbelly to get access to it now and in the future.

It works so much better and smoother now! Amazing what quality gets you
__________________

__________________
Bill
2016 Forest River 3250 Cardinal
2016 RAM 2500 Longhorn
Previously: 36' Country Coach
Havasu Bill is offline   Reply With Quote
Old 10-09-2016, 02:33 PM   #13
Junior Member
 
Join Date: Jan 2016
Posts: 5
We have a Chaparral 360IBL and the black tank handle was hard to from day 1 just like yours. After about a year of fighting with it, it finally won. It broke off in my hand one day. I pulled the underbelly skin off to get to it and discovered a major design flaw. The black tank is mounted about 10" in front of a cross brace. To route the cable to the blade valve, it had to make a 90* bend at the valve connection causing a huge amount of friction at the bend. My solution was to drill a 1/4" hole in the brace and run the cable from behind the brace straight into the valve connection. Smooth as silk now.
__________________
Goferbroke is offline   Reply With Quote
Old 10-09-2016, 04:37 PM   #14
Senior Member
 
Join Date: Apr 2015
Location: Ontario, California
Posts: 672
Quote:
Originally Posted by scbrown063 View Post
Thanks David.

Is it a direct pull handle or does it have that darn cable?
In our old rig, at about 7 years I changed the whole valve and NEW was so nice.
__________________
Tom48 is offline   Reply With Quote
Old 10-10-2016, 11:48 AM   #15
Senior Member
 
Join Date: Nov 2014
Posts: 494
I went through two cable operated black valves with poor results. I gave up and replaced with an electric valve. It has worked well and solved the problem.
__________________

__________________
Harkerr is offline   Reply With Quote
Reply

Tags
black, black tank, tank

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:55 PM.