Reply
 
Thread Tools Display Modes
Old 02-20-2013, 07:27 AM   #21
Trailer Trash
 
Join Date: Aug 2012
Location: MN
Posts: 608
Yup thanks for link and info. That will come in handy!
__________________

__________________
joelek is offline   Reply With Quote
Old 04-18-2013, 08:18 PM   #22
Junior Member
 
Join Date: Apr 2013
Posts: 6
Quote:
Originally Posted by joelek View Post
Not yet but it's winter here in MN.
How do you get the thin round covers off?
In our 320 the outer lens twists off/unscrews
__________________

__________________
DKB13 is offline   Reply With Quote
Old 04-18-2013, 08:26 PM   #23
Trailer Trash
 
Join Date: Aug 2012
Location: MN
Posts: 608
It's my understanding that the covers unscrew CCW about a 1/4 turn to release. Somebody else was saying they pry off via plastic tool to remove. I'm betting the unscrew 1/4 turn method is what I have.

Still winter in Buffalo, MN with a fresh 8" falling today and tomorrow. April 18th 2013 for the record books.
__________________
joelek is offline   Reply With Quote
Old 05-17-2013, 01:23 AM   #24
ETF
Member
 
Join Date: Mar 2013
Posts: 45
"Bump"

Thank goodness for this board.

On our maiden trip in our 3011DS we had one LED light fail. It's not a catastrophe but like others have said, I thought those things were indestructible (almost). I was going to wait until later in the year and have it fixed under warranty but I just couldn't wait. The whole canister just pulls out of the ceiling, it seems to be a friction fit, but I couldn't get the glass cover off. I thought of prying it off and did try in a half hearted way but it was going to take more brute force than I was willing to give it. Just as well as I just found out that that it comes off by turning it counter clockwise. I would have probably found that out after I forced it it off and broke something. Yup, experience is what you gain just after you totally mess something up.

Once again, thanks for all your informed opinions. It's a great help to us newbie MH owners.
__________________
ETF is offline   Reply With Quote
Old 05-17-2013, 08:03 AM   #25
Trailer Trash
 
Join Date: Aug 2012
Location: MN
Posts: 608
Mine is simply pull glass cover straight down. Others are turn 1/4 turn ccw then pull down. The 1/4 turn method works for either type. The lights are G4 pin mounts. They fit kind of loose in socket as pins are so small. Bumps from towing/traveling could jostle a light and make it appear burnt out. It may simply need to be pushed back into its socket to work again.

Below is example of G4 style pin mount. You have to pull one of yours to figure out glass globe style, led style/mount and how many smd leds your light has. smd = surface mount device. Columbus has used different styles throughout the couple of production years now.

Count how many led segments are on your bulb. Then go online to ebay, amazon, etc to order them. The dealer upcharge on these led lights is crazy. Order them by 6 pack, 10 pack, etc.

__________________
joelek is offline   Reply With Quote
Old 07-27-2013, 07:43 AM   #26
Junior Member
 
Join Date: Mar 2013
Location: Windham Centre, ON
Posts: 3
We bought our new Columbus 320rs in march of 2013, and the first time we had a chance to take it out was in June of this year. When we turn on our kitchen lights, or over the sink light, or the front bedroom light it cuts out the signal to our t.v. This is so annoying and something terribly wrong. We have contacted the place where we bought the fifth wheel, and they don't seem to concerned or they just don't want to bother with it. I would like to contact someone at Columbus to find out what they can do about it. Anyone know of this problem and what to do?
__________________
jewwels is offline   Reply With Quote
Old 07-27-2013, 09:14 AM   #27
Trailer Trash
 
Join Date: Aug 2012
Location: MN
Posts: 608
This is a well documented problem and nothing is terribly wrong other than it sucks. The straight fact is the cheaply made LED light bulbs (probably from China) do indeed screw up the television and radio reception. LED bulbs are the culprit. Google LED bulb signal interference and enjoy hours of reading. You will make it 5 minutes and get bored and ticked off at the same time.

So how do you fix this?
My fix and it's free is when watching TV or listening to radio, shut off LED lights and turn on the yellow globe lights. The yellow ones are halogen bulbs and those don't mess up the signal.

Another fix is to replace the LED bulb with a Halogen bulb. The bulbs in mine are G4 side pin base.

The 3rd and more expensive fix is to find higher quality more expensive LED bulbs that are guaranteed no radio/tv signal interference. I have not searched for this yet.

The biggest problem in the 320RS is LED lights in hallway going up to bedroom. That is were the basement radio and TV antenna wires are located. So turning on the hallway lights and/or lights close to is, messes up the reception signal.

So now you know the what and why. The dealer nor the factory have a fix for you and they are not going to deal with it. Nothing is wrong physically with your RV. The factory makes no guarantee on TV or radio reception.

Jewwels, this is your 1st post. Welcome to Forest River Forums. There is tons of info on here!
__________________
joelek is offline   Reply With Quote
Old 07-27-2013, 07:24 PM   #28
Junior Member
 
Join Date: Mar 2013
Location: Windham Centre, ON
Posts: 3
Hi!

Thank you for your response and help in my problem! All i have to say is shame on them!! I am not impressed with Columbus/Forest River for not checking all of this out before they installed LED lights.

I am not giving up though! Maybe they can change those LED lights to something that won't interfere with the t.v. and radio????

I will keep writing them and let you all know of any success with the company.

Thanks again, we appreciate it. hcananda2
__________________
jewwels is offline   Reply With Quote
Old 07-29-2013, 09:54 PM   #29
Columbus 302 rs
 
Join Date: May 2012
Location: Right now in Winchester Va.
Posts: 113
Palomino sent me 10 new LED light fixtures to replace those that I've had fail. The new fixtures have the LED array integrated into the fixture itself instead of like the previous two pin type array. I need to plug one in and see how the lumens and color compare to the original fixture array. I do see that the LED's are much smaller than the original. I'll give an update when I see the result. Thanks to Palomino for replacing the old units.
__________________
Columbus 320rs with Ford King Ranch F350
hanging in the Shenandoah Valley and catering
to QuickSilver our 18 year old photogenic cat.
TheEdge is offline   Reply With Quote
Old 07-30-2013, 07:41 AM   #30
Trailer Trash
 
Join Date: Aug 2012
Location: MN
Posts: 608
Post pics of the new bulb assembly!
__________________

__________________
joelek is offline   Reply With Quote
Reply

Tags
320rs, columbus, lamp, led, light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:06 PM.