Reply
 
Thread Tools Display Modes
Old 06-19-2013, 06:30 PM   #1
Junior Member
 
Join Date: May 2013
Posts: 18
Columbus WaterPur FR1/ KW1 Popped off

We have a new Columbus 320RS with the WaterPur filter system. The housing is model FR1 and the filter is model KW1. I attached the housing about two weeks ago and have been using it without a problem until today. I turned on the kitchen faucet, hear a popping noise outside, and then observed that the filter housing had popped off from its attachment. Fortunately, the drain plug to the service compartment was out and the water was running harmlessly to the ground.

I called Columbus service and they were very nice and said they would ship another complete unit to a nearby dealer within 48 hours. Not good, since we are traveling and need to be in the RV...can't use it without water.

I then tried to retighten the filter housing with the filter tool and turned it past the point of initial resistance and it than seemed to slip into place. Voila, turned the water back on and now have no leak.

I also called WaterPur and talked to a tech. He said they have no manual or instructions for their units....too much to expect in the RV world I suppose. But he did say that you have to be sure to turn the filter housing a full 180 degrees after it makes contact with the housing adapter and make sure it is tight.

Just wanted to give everyone a heads up, that although the filter house may be on an not leaking (mine didn't for two weeks), it has to be turned a full 180 degrees and be locked tight or it may come undone if the water pressure strong.
__________________

__________________
edenjw64 is offline   Reply With Quote
Old 06-22-2013, 05:27 PM   #2
Member
 
Join Date: Nov 2012
Location: Monroe Wa.
Posts: 45
I had the same problem and figured out the clear plastic housing needs to be DRY to seal properly or it will unwind itself with water pressure.

I finally replaced mine with a different style that definitely clicks into place and cannot come loose with pressure.

I also had a problem locating the filter from anyone other than Forest River. Not available from Camping World.

Thanks.

Jon
__________________

__________________
2001 Dodge 3500 4x4 dually
Exhaust brake, 4" SS exhaust
DDP injectors, Edge chip
B&W hitch
2013 Columbus Palomino 295RL
Jon_Celia is offline   Reply With Quote
Old 06-24-2013, 01:28 PM   #3
Junior Member
 
Join Date: May 2013
Posts: 18
Jon_Ceclua, What type of filter housing did you use to replace the original? The strange thing about ours was that it was leak free for a couple of weeks before it came off unexpectedly. I'm pretty sure the seal on the housing was dry when I first installed it, but I don't think I tightened it the full 180 degrees like the WaterPur tech recommended. So far it has not come off again, but I visually check it every day on so to be sure it's not untwisting.
__________________
edenjw64 is offline   Reply With Quote
Old 06-24-2013, 10:20 PM   #4
Member
 
Join Date: Nov 2012
Location: Monroe Wa.
Posts: 45
I went to my local Camping World and went with the EverPur water filter and canister. I plumbed it on the side instead of the back of the water closet wall so I could have easier access to the water connections.

The water filter system works great. I keep the pressure at 55lbs. and there is plenty of water in the trailer.

Hope this helps.

Thanks.

Jon
__________________
2001 Dodge 3500 4x4 dually
Exhaust brake, 4" SS exhaust
DDP injectors, Edge chip
B&W hitch
2013 Columbus Palomino 295RL
Jon_Celia is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


All times are GMT -5. The time now is 03:10 PM.