Reply
 
Thread Tools Display Modes
Old 06-21-2014, 07:34 PM   #1
Senior Member
 
Pirates55's Avatar
 
Join Date: Jan 2014
Location: China Grove, NC
Posts: 297
Commode issue

Has anyone ever had an issue with their commode not shutting off completely after you flush it.

My parents camper has the foot pedal flush on their commode but after you flush you have to pull it up it will not shut on its on.

Any ideas where to start in fixing the issue???
__________________

__________________
Pirates55 is offline   Reply With Quote
Old 06-21-2014, 07:53 PM   #2
Senior Member
 
camper1999's Avatar
 
Join Date: Feb 2012
Posts: 778
Sounds like a bad valve. Generally pretty easy to replace. About 26 bucks
__________________

__________________
2012 Cedar Creek Silverback 29RE
2011 GMC 2500HD Diesel
camper1999 is offline   Reply With Quote
Old 06-21-2014, 07:58 PM   #3
Mod free 5er
 
Join Date: Mar 2008
Location: Concord, NC
Posts: 24,215
Pull the valve, take it apart and lube everything with a silicone paste lube like Danco and put it back together. Mine was replace under warranty and a year later did the same thing again. I took it apart, lubed it and it works great a year later.

1 2 oz Container Waterproof Grease 80360 Danco | eBay
__________________
OldCoot is offline   Reply With Quote
Reply

Tags
modifications

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:57 AM.