Thread Tools Display Modes
Old 07-05-2014, 03:12 AM   #1
Chuck P.
Join Date: Sep 2012
Location: Novi, MI
Posts: 9
NAXA Model 670 Radio Issue

I inserted a CD yesterday and this thing went totally dead. No blown fuses, wiring looks solid. Does anyone have any experience with this unit? It appears to be a piece of junk, but it ate my CD and now can't eject it.

chasphill is offline   Reply With Quote
Old 07-08-2014, 08:00 PM   #2
Junior Member
Join Date: May 2013
Location: Louisiana
Posts: 28
Make sure the face piece is properly attached. If so, press power button a couple of times to see if it powers up. Press CD eject button a couple of times. Should eject whether radio is on or off. I hope this works, good luck.
2013 Columbus 365RL

It's All Good!!!
Geeza42 is offline   Reply With Quote

radio, modifications

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:51 AM.