Reply
 
Thread Tools Display Modes
Old 08-15-2010, 10:28 AM   #1
Junior Member
 
Join Date: Aug 2010
Posts: 4
Power issues 09 thoroughbred

Brand new 09 lost power to TV/entertainment center and all of the outlets. I checked the fuses and everything seems alright. Any ideas?
__________________

__________________
wjhfisher is offline   Reply With Quote
Old 08-15-2010, 10:29 AM   #2
Member
 
Join Date: Jun 2010
Location: Gardner, MA
Posts: 57
Check the gfi..
__________________

__________________
2011 Sierra 35 Loft TreeHouse
2006 Dodge 3500
Better Photo
Mowat is offline   Reply With Quote
Old 08-15-2010, 11:34 AM   #3
Junior Member
 
Join Date: Aug 2010
Posts: 4
Any idea were its located
__________________
wjhfisher is offline   Reply With Quote
Old 08-15-2010, 11:35 AM   #4
Senior Member
 
NWJeeper's Avatar
 
Join Date: Aug 2008
Location: Enumclaw, WA
Posts: 2,617
Depending on the rig, you will have a GFI in the batroom and one in the Kitchen.
__________________
"I can fix it, and if I can't fix it, I can fix it so no one can fix it!"
Ed & Wendy
2009 Georgetown 378TS | 1998 Jeep Wrangler | 1998 Skeeter ZX202C
Nights camped in 2009: 53 | Nights camped in 2010: 55
www.nwjeepn.com
NWJeeper is offline   Reply With Quote
Old 08-15-2010, 11:41 AM   #5
Junior Member
 
Join Date: Aug 2010
Posts: 4
Thks
__________________
wjhfisher is offline   Reply With Quote
Old 08-15-2010, 11:51 AM   #6
Member
 
Join Date: Jun 2010
Location: Gardner, MA
Posts: 57
Sadly they gang most all of the plugs onto usually 1 gfi. I found all but 2 of the 15ish plugs all led to one gfi plug. Trip that and everything from the tv to the outside fridge stops working. And yes mine is in the bathroom
__________________
2011 Sierra 35 Loft TreeHouse
2006 Dodge 3500
Better Photo
Mowat is offline   Reply With Quote
Old 08-19-2010, 07:57 PM   #7
Junior Member
 
Join Date: Aug 2010
Posts: 4
GFI to the right of the bed in the master bedroom, and it got the TV on and the outlets the dvd player has power but won't come on.
__________________
wjhfisher is offline   Reply With Quote
Old 08-19-2010, 09:19 PM   #8
Member
 
Join Date: Jun 2010
Location: Gardner, MA
Posts: 57
well.. good thing is you got power !!...

Bad thing is you might have a bad dvd player. Look around on the forums lots of people have had issues and there are multitude of resolutions.
__________________
2011 Sierra 35 Loft TreeHouse
2006 Dodge 3500
Better Photo
Mowat is offline   Reply With Quote
Old 08-20-2010, 08:21 AM   #9
Owner - RVtronics
 
Bob Fields's Avatar
 
Join Date: Jul 2010
Location: Massachusetts
Posts: 649
Send a message via AIM to Bob Fields Send a message via Skype™ to Bob Fields
Quote:
Originally Posted by Mowat View Post
well.. good thing is you got power !!...

Bad thing is you might have a bad dvd player. Look around on the forums lots of people have had issues and there are multitude of resolutions.
You guys crack me up.

Really, is the DVD in this RV broken? What kind of DVD is it? What is the problem it is having?

And if there no problems today, just wait you'll have one some day!
__________________
Bob Fields
bob@rvtronics.com
www.rvtronics.com
(781) 281-9440
Bob Fields is offline   Reply With Quote
Old 08-20-2010, 10:25 AM   #10
Member
 
Join Date: Jun 2010
Location: Gardner, MA
Posts: 57
Whoa there bob... That wasn't a bashing post... relax.
__________________

__________________
2011 Sierra 35 Loft TreeHouse
2006 Dodge 3500
Better Photo
Mowat is offline   Reply With Quote
Reply

Tags
palomino

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:55 PM.