Reply
 
Thread Tools Display Modes
Old 06-20-2017, 12:19 PM   #1
Junior Member
 
Join Date: Jun 2017
Posts: 6
Puma 31RLQS radio and sound system on

I just bought a 2018 Puma 31RLQS and the radio and entertainment system are on but not putting out sound or allowing me to change stations or modes. I have tried the remote and the buttins on the devices and still no sound or mode change.
__________________

Tpleibel is offline   Reply With Quote
Old 06-20-2017, 12:48 PM   #2
Member
 
Join Date: Jun 2016
Location: Ohio - AZ
Posts: 34
Entertainment system not working

Did it work when you took delivery from the dealer? Either way, I'd head back there for a fix or some instruction.

Good luck!
__________________

Ohinaz1970 is offline   Reply With Quote
Old 06-21-2017, 12:02 PM   #3
Junior Member
 
Join Date: Jun 2017
Posts: 6
It was working when I picked it up. Unfortunately even if the dealer wasn't 350 miles away, I wouldn't trust them to clean dog poo. Worst buying experience I ever had. I guess I will have to find a local authorized service dealer. I was hoping someone knew a reset.
Tpleibel is offline   Reply With Quote
Old 06-24-2017, 09:22 AM   #4
Missing Link
 
cyclepuck's Avatar
 
Join Date: Apr 2012
Location: Genesee, MI
Posts: 415
In laws had similar issue. What fixed theirs was pulling the fuse for a minutes and it reset.
__________________
2014 Puma 30-DBSS
2014 Ram 2500 Mega Cab 6.4L
cyclepuck is offline   Reply With Quote
Old 06-24-2017, 09:31 AM   #5
Junior Member
 
Join Date: Jun 2017
Posts: 6
I will try the fuse thing this morning and post how it goes.
Tpleibel is offline   Reply With Quote
Old 06-25-2017, 07:24 PM   #6
Junior Member
 
Join Date: Jun 2017
Posts: 6
Lots of fuses and none labeled. All the breakers are though.
Tpleibel is offline   Reply With Quote
Old 07-09-2017, 06:26 AM   #7
Missing Link
 
cyclepuck's Avatar
 
Join Date: Apr 2012
Location: Genesee, MI
Posts: 415
Just pull fuses till it losses power.
__________________
2014 Puma 30-DBSS
2014 Ram 2500 Mega Cab 6.4L
cyclepuck is offline   Reply With Quote
Old 07-09-2017, 06:30 AM   #8
Junior Member
 
Join Date: Jun 2017
Posts: 6
I did the fuse thing. Went ahead and did them all and labeled them. It's working now. Thank for all the help.
Tpleibel is offline   Reply With Quote
Old 07-19-2017, 05:51 PM   #9
Junior Member
 
Join Date: Jul 2016
Location: Central Indiana
Posts: 27
I have the Furrion system in my Puma and the Bluetooth was giving me some issues (not playing - just buzzing. I hit the reset button on front of unit and it fixed the issue. Now I keep a paper clip on board for not if, but when it happens again. May be easier than pulling fuses for ya. Not a great sound system, but gets me by for as often as we use it.

Good luck.
__________________

__________________
2019 Puma 31RLQS
2016 Chevy Silverado 2500 HD Crew Cab (6.0)
jdelp is offline   Reply With Quote
Reply

Tags
puma, radio

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:58 AM.